summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-11 08:24:04 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-11 09:48:04 +0100
commit3611457ecf4e3a55455499f03579e3cec447fc01 (patch)
treed5f037621b6394583f8de2125705690c20ba3dd6
parentdev-python/pypy3-exe-bin: Bump to 7.3.3_p37_p2 (unicode dec fix) (diff)
downloadgentoo-3611457ecf4e3a55455499f03579e3cec447fc01.tar.gz
gentoo-3611457ecf4e3a55455499f03579e3cec447fc01.tar.bz2
gentoo-3611457ecf4e3a55455499f03579e3cec447fc01.zip
dev-python/fqdn: Bump to 1.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/fqdn/Manifest1
-rw-r--r--dev-python/fqdn/fqdn-1.5.1.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/fqdn/Manifest b/dev-python/fqdn/Manifest
index 63ee2cc69361..f388ea02acac 100644
--- a/dev-python/fqdn/Manifest
+++ b/dev-python/fqdn/Manifest
@@ -1 +1,2 @@
DIST fqdn-1.5.0.tar.gz 14630 BLAKE2B 021b4e53c42830a5523964961cde9857bea9eb700cd2030331b05006ec4a8b7e05a9f2330748b0d84531526e17d81ade73fb04e65db381417f2d7f618138f09a SHA512 3940955df50bcd0bbd5cae82f148e9a8ef64b6db84dc867fbfbfbdd661fcc42208a7506f931209347f9115722c00e330fc03c5bdd459cb4a98d0df59af48c492
+DIST fqdn-1.5.1.tar.gz 18334 BLAKE2B 24dfd88a8176e67209350fe20e446cfee848c392795cde09725526a52af0a9adc6908a4eb6d5dd3ad6f8a11546acb6b82a7b2ad591997010dfdd0a1d235f57ae SHA512 d9d7d1bb8798c63973534bf45fb9bc0ab57b1600c6597212129debb97a908140401f5477f33b83ea273e3f9a2a852072110245a09596ab9a58a10be8043c57fc
diff --git a/dev-python/fqdn/fqdn-1.5.1.ebuild b/dev-python/fqdn/fqdn-1.5.1.ebuild
new file mode 100644
index 000000000000..91ac88a37d86
--- /dev/null
+++ b/dev-python/fqdn/fqdn-1.5.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2018-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="RFC-compliant FQDN validation and manipulation for Python"
+HOMEPAGE="https://github.com/ypcrts/fqdn"
+SRC_URI="https://github.com/ypcrts/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/cached-property[${PYTHON_USEDEP}]
+ ' python3_7 pypy3)"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs