summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2018-01-15 21:09:39 -0500
committerMike Frysinger <vapier@gentoo.org>2018-01-15 21:09:55 -0500
commit394df8fbb8cf7a0b9f48b5baf588e048e934857b (patch)
tree51e7b92ee548fc8164ff0c9bd3f8ad2db009a7ef
parentprofiles: Stable-mask sci-libs/plplot[tcl] (diff)
downloadgentoo-394df8fbb8cf7a0b9f48b5baf588e048e934857b.tar.gz
gentoo-394df8fbb8cf7a0b9f48b5baf588e048e934857b.tar.bz2
gentoo-394df8fbb8cf7a0b9f48b5baf588e048e934857b.zip
net-misc/igmpproxy: version bump to 0.2 #642160
Closes: https://bugs.gentoo.org/642160
-rw-r--r--net-misc/igmpproxy/Manifest1
-rw-r--r--net-misc/igmpproxy/igmpproxy-0.2.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/net-misc/igmpproxy/Manifest b/net-misc/igmpproxy/Manifest
index dc74142f3b00..e90ba0d238df 100644
--- a/net-misc/igmpproxy/Manifest
+++ b/net-misc/igmpproxy/Manifest
@@ -1 +1,2 @@
DIST igmpproxy-0.1.tar.gz 140159 BLAKE2B d4a0fb0f69f1e8c7221ecd2842e95cfa390f54885d5eaaa5c69a32563b318a05540e123d4b19cd63a930d17934c1344fdf6467fad5c1de333d03e0a802e7912b SHA512 1a569814d8984610402313d8c4adb78ff362f82ae28c968a8ba0fb411e12a704d1b51b387111b51517ab8fb2e86952bbd196f27eccd311c11ce288fc6fa25ad4
+DIST igmpproxy-0.2.tar.gz 170705 BLAKE2B a2a13399995f283fb77b500140c1750ed306511eb5f51a71491edc245c8d8f873809fac9a82dc7ba0be7a7390643d85d7f4a2a8521b3c2c20fb8f09ad33b507d SHA512 a06f95c912456191d0953c08058ccb987120f6b11426d15e329c2de95878b9fc6ee5742b253e2c06b8002771478c382a58a14a0af76fb835ebb1d132b9f34e4f
diff --git a/net-misc/igmpproxy/igmpproxy-0.2.ebuild b/net-misc/igmpproxy/igmpproxy-0.2.ebuild
new file mode 100644
index 000000000000..92b9f1240bdc
--- /dev/null
+++ b/net-misc/igmpproxy/igmpproxy-0.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit linux-info systemd
+
+DESCRIPTION="Multicast Routing Daemon using only IGMP signalling"
+HOMEPAGE="https://github.com/pali/igmpproxy"
+SRC_URI="https://github.com/pali/igmpproxy/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2 Stanford"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+CONFIG_CHECK="~IP_MULTICAST ~IP_MROUTE"
+
+src_install() {
+ emake DESTDIR="${D}" install
+ newinitd "${FILESDIR}/${PN}-init.d" ${PN}
+ newconfd "${FILESDIR}/${PN}-conf.d" ${PN}
+ systemd_dounit "${FILESDIR}/${PN}.service"
+}