summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2023-12-18 14:32:07 -0500
committerMichał Górny <mgorny@gentoo.org>2023-12-21 04:27:25 +0100
commit3abfecdb211b7f68499f2012e287f0197d53fbd9 (patch)
treea734f79bc84787b24d9357ec5b3bd9a558c6eac7
parentdev-python/pypy3_9: fixup compileall call excludes (diff)
downloadgentoo-3abfecdb211b7f68499f2012e287f0197d53fbd9.tar.gz
gentoo-3abfecdb211b7f68499f2012e287f0197d53fbd9.tar.bz2
gentoo-3abfecdb211b7f68499f2012e287f0197d53fbd9.zip
dev-python/pypy3_10: fixup compileall call excludes
There's a bunch of testdata that isn't supposed to be compiled. The CPython build system automatically excludes it, but PyPy doesn't have a build system so we must do it manually. The original implementation passes the excludes args after the operand, which is unreliable across PyPy versions. For consistency, specify them before. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pypy3_10/pypy3_10-7.3.13_p3.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-python/pypy3_10/pypy3_10-7.3.13_p3.ebuild b/dev-python/pypy3_10/pypy3_10-7.3.13_p3.ebuild
index 602fae3f411e..409ff106d0a3 100644
--- a/dev-python/pypy3_10/pypy3_10-7.3.13_p3.ebuild
+++ b/dev-python/pypy3_10/pypy3_10-7.3.13_p3.ebuild
@@ -203,8 +203,8 @@ src_install() {
einfo "Byte-compiling Python standard library..."
# exclude list from CPython Makefile.pre.in
"${PYTHON}" -m compileall -j "$(makeopts_jobs)" -o 0 -o 1 -o 2 \
- --hardlink-dupes -q -f -d "${dest}" "${ED}${dest}" \
- -x 'bad_coding|badsyntax|site-packages|lib2to3/tests/data' || die
+ -x 'bad_coding|badsyntax|site-packages|lib2to3/tests/data' \
+ --hardlink-dupes -q -f -d "${dest}" "${ED}${dest}" || die
# remove to avoid collisions
rm "${PYTHON}" || die