summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-08-16 23:16:59 -0700
committerMatt Turner <mattst88@gentoo.org>2021-08-16 23:32:52 -0700
commit3dd83356a9d78dc47f2977769fc433adb1e22649 (patch)
tree4c5ceb9fec0a45fb51e5b41b9b073fdaf14c8f49
parentdev-lang/vala: Version bump to 0.52.5 (diff)
downloadgentoo-3dd83356a9d78dc47f2977769fc433adb1e22649.tar.gz
gentoo-3dd83356a9d78dc47f2977769fc433adb1e22649.tar.bz2
gentoo-3dd83356a9d78dc47f2977769fc433adb1e22649.zip
www-client/epiphany: Version bump to 40.3
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--www-client/epiphany/Manifest1
-rw-r--r--www-client/epiphany/epiphany-40.3.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/www-client/epiphany/Manifest b/www-client/epiphany/Manifest
index 19e352bf4424..73522be10ea2 100644
--- a/www-client/epiphany/Manifest
+++ b/www-client/epiphany/Manifest
@@ -1 +1,2 @@
DIST epiphany-40.2.tar.xz 5372180 BLAKE2B cd75f645980c37b0cdd92133505cf7961168bf5d67ad0bdf3140f155c737a070f7ffafa63bb8a0e5de175826b79b2ca380a2851e7f1f0454d4f372d48f48c9c7 SHA512 29a5b7e65f7e5decb3c370fc9ae654727cce30f397ffd3289a9f77f3527f0471c821e3bea0f1a5ab9c1ab44e670898b46e66e41de5cb8c76fabd23b135a4a1a9
+DIST epiphany-40.3.tar.xz 5379072 BLAKE2B d0b2ecd5db6953261efe6658fe60798b93b6589e1c79032f659a3d69dcf1e2ed77156bf46768c2891916a48f9a28474f8690e451c8631a0455f06d525f9349b5 SHA512 86d896142171f50d0375c4efec370986741d89f341b613c137fb4719ba5359a9e5523e52635c4bcc9ac7acf96f2276486d878d5ed44a57bc1c8124a01af2d30d
diff --git a/www-client/epiphany/epiphany-40.3.ebuild b/www-client/epiphany/epiphany-40.3.ebuild
new file mode 100644
index 000000000000..6e19aa0daada
--- /dev/null
+++ b/www-client/epiphany/epiphany-40.3.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org gnome2-utils meson xdg virtualx
+
+DESCRIPTION="GNOME webbrowser based on Webkit"
+HOMEPAGE="https://wiki.gnome.org/Apps/Web"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.64.0:2
+ >=x11-libs/gtk+-3.24.0:3
+ >=dev-libs/nettle-3.4:=
+ >=net-libs/webkit-gtk-2.31.1:4=
+ >=x11-libs/cairo-1.2
+ >=app-crypt/gcr-3.5.5:=[gtk]
+ >=x11-libs/gdk-pixbuf-2.36.5:2
+ gnome-base/gsettings-desktop-schemas
+ >=app-text/iso-codes-0.35
+ >=dev-libs/json-glib-1.2.4
+ app-arch/libarchive:=
+ >=dev-libs/libdazzle-3.37.1
+ >=gui-libs/libhandy-1.1.0:1=
+ >=x11-libs/libnotify-0.5.1
+ >=app-crypt/libsecret-0.19
+ >=net-libs/libsoup-2.48.0:2.4
+ >=dev-libs/libxml2-2.6.12:2
+ >=dev-db/sqlite-3.22:3
+ dev-libs/gmp:0=
+"
+RDEPEND="${DEPEND}
+ x11-themes/adwaita-icon-theme
+"
+# appstream-glib needed for appdata.xml gettext translation
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # Allow /var/tmp prefixed recursive delete (due to package manager setting TMPDIR)
+ "${FILESDIR}"/var-tmp-tests.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ -Ddeveloper_mode=false
+ -Dlibportal=disabled
+ # maybe enable later if network-sandbox is off, but in 3.32.4 the network test
+ # is commented out upstream anyway
+ -Dnetwork_tests=disabled
+ -Dtech_preview=false
+ $(meson_feature test unit_tests)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ if ! has_version net-libs/webkit-gtk[jpeg2k]; then
+ ewarn "Your net-libs/webkit-gtk is built without USE=jpeg2k."
+ ewarn "Various image galleries/managers may be broken."
+ fi
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}