summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-08-26 17:59:42 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-08-26 20:23:49 +0200
commit3e34941e0fb1110f3aabefd994630b7702c35f2e (patch)
treee3e1e9c4685ad043e5106cd6e8e024b3d6416a40
parentsys-apps/man: Remove support for non-existent deps (diff)
downloadgentoo-3e34941e.tar.gz
gentoo-3e34941e.tar.bz2
gentoo-3e34941e.zip
sci-libs/dcmtk: Put || die where || die belongs
Package-Manager: Portage-2.3.48, Repoman-2.3.10
-rw-r--r--sci-libs/dcmtk/dcmtk-3.6.0.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/sci-libs/dcmtk/dcmtk-3.6.0.ebuild b/sci-libs/dcmtk/dcmtk-3.6.0.ebuild
index 414724b2e234..1a94d20b5063 100644
--- a/sci-libs/dcmtk/dcmtk-3.6.0.ebuild
+++ b/sci-libs/dcmtk/dcmtk-3.6.0.ebuild
@@ -55,7 +55,7 @@ src_prepare() {
# fix -D deprecation warnings
sed -i -e "s|_BSD_SOURCE|_DEFAULT_SOURCE|g" \
"${S}"/config/configure.in \
- "${S}"/CMakeLists.txt
+ "${S}"/CMakeLists.txt || die
}
src_configure() {
@@ -74,7 +74,7 @@ src_configure() {
cmake-utils_src_configure
if use doc; then
- cd "${S}"/doxygen
+ cd "${S}"/doxygen || die
econf
fi
}
@@ -83,16 +83,16 @@ src_compile() {
cmake-utils_src_compile
if use doc; then
- emake -C "${S}"/doxygen || die
+ emake -C "${S}"/doxygen
fi
}
src_install() {
cmake-utils_src_install
- doman doxygen/manpages/man1/* || die
+ doman doxygen/manpages/man1/*
if use doc; then
- dohtml -r "${S}"/doxygen/htmldocs/* || die
+ dohtml -r "${S}"/doxygen/htmldocs/*
fi
}