summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-libs/dcmtk/dcmtk-3.6.0.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/sci-libs/dcmtk/dcmtk-3.6.0.ebuild b/sci-libs/dcmtk/dcmtk-3.6.0.ebuild
index 414724b2e234..1a94d20b5063 100644
--- a/sci-libs/dcmtk/dcmtk-3.6.0.ebuild
+++ b/sci-libs/dcmtk/dcmtk-3.6.0.ebuild
@@ -55,7 +55,7 @@ src_prepare() {
# fix -D deprecation warnings
sed -i -e "s|_BSD_SOURCE|_DEFAULT_SOURCE|g" \
"${S}"/config/configure.in \
- "${S}"/CMakeLists.txt
+ "${S}"/CMakeLists.txt || die
}
src_configure() {
@@ -74,7 +74,7 @@ src_configure() {
cmake-utils_src_configure
if use doc; then
- cd "${S}"/doxygen
+ cd "${S}"/doxygen || die
econf
fi
}
@@ -83,16 +83,16 @@ src_compile() {
cmake-utils_src_compile
if use doc; then
- emake -C "${S}"/doxygen || die
+ emake -C "${S}"/doxygen
fi
}
src_install() {
cmake-utils_src_install
- doman doxygen/manpages/man1/* || die
+ doman doxygen/manpages/man1/*
if use doc; then
- dohtml -r "${S}"/doxygen/htmldocs/* || die
+ dohtml -r "${S}"/doxygen/htmldocs/*
fi
}