summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-04-22 01:54:08 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-04-22 02:51:04 -0400
commit3ef7d44bd6ac080cae78a6bf3a8c6748ddc19fc7 (patch)
tree138db5172d2c68a74c2eee9379357cb9a97d63fb
parentdev-python/PyQt6: set DISTUTILS_EXT=1 (diff)
downloadgentoo-3ef7d44bd6ac080cae78a6bf3a8c6748ddc19fc7.tar.gz
gentoo-3ef7d44bd6ac080cae78a6bf3a8c6748ddc19fc7.tar.bz2
gentoo-3ef7d44bd6ac080cae78a6bf3a8c6748ddc19fc7.zip
dev-python/PyQt6: respect CPPFLAGS
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--dev-python/PyQt6/PyQt6-6.4.2.ebuild2
-rw-r--r--dev-python/PyQt6/PyQt6-6.5.0.ebuild2
2 files changed, 4 insertions, 0 deletions
diff --git a/dev-python/PyQt6/PyQt6-6.4.2.ebuild b/dev-python/PyQt6/PyQt6-6.4.2.ebuild
index ccee7f8cdba7..cf5de2a490c4 100644
--- a/dev-python/PyQt6/PyQt6-6.4.2.ebuild
+++ b/dev-python/PyQt6/PyQt6-6.4.2.ebuild
@@ -78,7 +78,9 @@ src_prepare() {
}
src_configure() {
+ append-cppflags $(usex debug -{U,D}NDEBUG) # not set by eclass "yet"
append-cxxflags -std=c++17 # for old gcc / clang that use <17 (bug #892331)
+ append-cxxflags ${CPPFLAGS} # respect CPPFLAGS
pyqt-use_enable() {
local state=$(usex ${1} --enable= --disable=)
diff --git a/dev-python/PyQt6/PyQt6-6.5.0.ebuild b/dev-python/PyQt6/PyQt6-6.5.0.ebuild
index 0944c1869eab..a731a68b3575 100644
--- a/dev-python/PyQt6/PyQt6-6.5.0.ebuild
+++ b/dev-python/PyQt6/PyQt6-6.5.0.ebuild
@@ -79,7 +79,9 @@ src_prepare() {
}
src_configure() {
+ append-cppflags $(usex debug -{U,D}NDEBUG) # not set by eclass "yet"
append-cxxflags -std=c++17 # for old gcc / clang that use <17 (bug #892331)
+ append-cxxflags ${CPPFLAGS} # respect CPPFLAGS
pyqt-use_enable() {
local state=$(usex ${1} --enable= --disable=)