summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-05-03 18:37:50 -0500
committerAustin English <wizardedit@gentoo.org>2016-05-03 19:08:37 -0500
commit4086fcda8bbd8653111ff2c8b29d4d897cc600be (patch)
tree62d93fdfec208e6612bc9bb06e3e76c87c2c92a6
parentnet-misc/iaxmodem: remove old versions (diff)
downloadgentoo-4086fcda8bbd8653111ff2c8b29d4d897cc600be.tar.gz
gentoo-4086fcda8bbd8653111ff2c8b29d4d897cc600be.tar.bz2
gentoo-4086fcda8bbd8653111ff2c8b29d4d897cc600be.zip
net-misc/igmpproxy: use #!/sbin/openrc-run instead of #!/sbin/runscript
Gentoo-Bug: https://bugs.gentoo.org/573846 Package-Manager: portage-2.2.26
-rw-r--r--net-misc/igmpproxy/files/igmpproxy-init.d4
-rw-r--r--net-misc/igmpproxy/igmpproxy-0.1-r2.ebuild25
2 files changed, 27 insertions, 2 deletions
diff --git a/net-misc/igmpproxy/files/igmpproxy-init.d b/net-misc/igmpproxy/files/igmpproxy-init.d
index 0b138c3b5c41..e24952ed18d0 100644
--- a/net-misc/igmpproxy/files/igmpproxy-init.d
+++ b/net-misc/igmpproxy/files/igmpproxy-init.d
@@ -1,5 +1,5 @@
-#!/sbin/runscript
-# Copyright 1999-2009 Gentoo Foundation
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
diff --git a/net-misc/igmpproxy/igmpproxy-0.1-r2.ebuild b/net-misc/igmpproxy/igmpproxy-0.1-r2.ebuild
new file mode 100644
index 000000000000..bda21a85cbfe
--- /dev/null
+++ b/net-misc/igmpproxy/igmpproxy-0.1-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit linux-info systemd
+
+DESCRIPTION="Multicast Routing Daemon using only IGMP signalling (Internet Group Management Protocol)"
+HOMEPAGE="http://sourceforge.net/projects/igmpproxy"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 Stanford"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+CONFIG_CHECK="~IP_MULTICAST ~IP_MROUTE"
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ newinitd "${FILESDIR}/${PN}-init.d" ${PN}
+ newconfd "${FILESDIR}/${PN}-conf.d" ${PN}
+ systemd_dounit "${FILESDIR}/${PN}.service"
+}