summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-12-02 09:08:11 -0500
committerMatt Turner <mattst88@gentoo.org>2022-12-02 09:35:32 -0500
commit41480a77d02d002dea7119c51cb6801ca6cd7e39 (patch)
tree18a90d4242d65b73715f9381fa1674f041e18af6
parentdev-python/google-auth: enable py3.11 (diff)
downloadgentoo-41480a77d02d002dea7119c51cb6801ca6cd7e39.tar.gz
gentoo-41480a77d02d002dea7119c51cb6801ca6cd7e39.tar.bz2
gentoo-41480a77d02d002dea7119c51cb6801ca6cd7e39.zip
dev-cpp/mm-common: Version bump to 1.0.5
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--dev-cpp/mm-common/Manifest1
-rw-r--r--dev-cpp/mm-common/mm-common-1.0.5.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-cpp/mm-common/Manifest b/dev-cpp/mm-common/Manifest
index f45676cec67a..a27d79b665f6 100644
--- a/dev-cpp/mm-common/Manifest
+++ b/dev-cpp/mm-common/Manifest
@@ -1 +1,2 @@
DIST mm-common-1.0.4.tar.xz 290164 BLAKE2B 2731c501ed79d2481b9094639bad1971e5a27e6416a7433982481e939bd44202f7e5769f3a9dbe5b7fd2e09a3f7bd4687d7ce85d79dafa877f5cc3c333f9d526 SHA512 e686f19cb4d40a3dda68e30b98b43fca3db51b387e28f5569bef0cfbb1cc3a7d72503ec5dfa0f2621dd349ac4c9c21f0fe93bdda224026534c509fbb60400243
+DIST mm-common-1.0.5.tar.xz 290608 BLAKE2B fcd698e8122fbcbcefcc6cce9460216cb3c3eabb17b309a28b964c9cd99b1329f936070f54b888cf0712e4590b8fe99394a110997ff023ff07dd7a30e55d771b SHA512 bf681b4d63d5bf531a9315b0c8841e3815af276828d1828a3eb04dcb805cbbfbaac182f79f5e48688a7eef8666975b9079144e320093e4ee3addff48813e61ad
diff --git a/dev-cpp/mm-common/mm-common-1.0.5.ebuild b/dev-cpp/mm-common/mm-common-1.0.5.ebuild
new file mode 100644
index 000000000000..6c75fe90f747
--- /dev/null
+++ b/dev-cpp/mm-common/mm-common-1.0.5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+inherit gnome.org python-any-r1 meson
+
+DESCRIPTION="Build infrastructure and utilities for GNOME C++ bindings"
+HOMEPAGE="https://www.gtkmm.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+BDEPEND="${PYTHON_DEPS}"
+
+src_prepare() {
+ default
+
+ # Include project version in docdir name
+ sed -i -e "s:^install_docdir.*:& + '-' + meson.project_version():" meson.build || die
+}