summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-07-06 06:38:59 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2021-07-06 06:38:59 +0200
commit423d43c6536ad645c15ec71f6922cfc66fa22f41 (patch)
tree941f8522ba21d29c970084db3f99b3592b3810aa
parentmedia-sound/qsynth: bump to 0.9.4 (diff)
downloadgentoo-423d43c6.tar.gz
gentoo-423d43c6.tar.bz2
gentoo-423d43c6.zip
media-sound/qsampler: bump to 0.9.4
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
-rw-r--r--media-sound/qsampler/Manifest1
-rw-r--r--media-sound/qsampler/qsampler-0.9.4.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/media-sound/qsampler/Manifest b/media-sound/qsampler/Manifest
index 0b73e929da09..e6d07841dc8e 100644
--- a/media-sound/qsampler/Manifest
+++ b/media-sound/qsampler/Manifest
@@ -1 +1,2 @@
DIST qsampler-0.9.3.tar.gz 283882 BLAKE2B 1171de42c7f27481a5e2f95c1d868b68594288d3a640fe118df9a7f1588d0fea73e06bad4d3acd08a99ec4ccceaee7d171a047a96e811be09ebb3c48896e064f SHA512 0abfcb35aafb773d1b0f2c31406ea7b04581a4a47b01074c70d1b4833a3f06e8223cfa57b1e7f0233bc347636f41732db37150e5bfde76ccaad4eb959428a7ba
+DIST qsampler-0.9.4.tar.gz 284055 BLAKE2B 83f0eb7102d6dbba994d2efeee59ebc46ce2b07d40b9dcfe97ed3059fefd449fa90167718ef65ef41f04709ef9c985c86e2b35a0572b47a948172cf5b1a5dc23 SHA512 0e43a335c503bd76d41bfe88967b199bcd8c34a44a65293c1460daa342ca1e35f236984af74e30404637e9f6c8428b4cc52fc27501af7d52e1c9e30f1a80d35e
diff --git a/media-sound/qsampler/qsampler-0.9.4.ebuild b/media-sound/qsampler/qsampler-0.9.4.ebuild
new file mode 100644
index 000000000000..d948252e61b9
--- /dev/null
+++ b/media-sound/qsampler/qsampler-0.9.4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake qmake-utils xdg
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://git.code.sf.net/p/qsampler/code"
+ inherit git-r3
+else
+ SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Graphical frontend to the LinuxSampler engine"
+HOMEPAGE="https://qsampler.sourceforge.io/ https://www.linuxsampler.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="debug +libgig"
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ media-libs/alsa-lib
+ media-libs/liblscp:=
+ x11-libs/libX11
+ libgig? ( media-libs/libgig:= )
+"
+RDEPEND="${DEPEND}
+ media-sound/linuxsampler
+"
+BDEPEND="dev-qt/linguist-tools:5"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.9.1-cmake-no-git.patch"
+)
+
+DOCS=( AUTHORS ChangeLog README TODO TRANSLATORS )
+
+src_prepare() {
+ cmake_src_prepare
+
+ sed -e "/^find_package.*QT/s/Qt6 //" -i CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCONFIG_DEBUG=$(usex debug 1 0)
+ -DCONFIG_LIBGIG=$(usex libgig 1 0)
+ )
+ cmake_src_configure
+}