summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-01-29 15:33:12 -0800
committerPatrick McLean <chutzpah@gentoo.org>2020-01-29 16:21:19 -0800
commit42e246629f37cababfeadfe36929b0cce828c37b (patch)
tree753bb8a4983694e5125d2b468dbff2f2afd6f87b
parentdev-lang/erlang: bump up to 22.2.4 (diff)
downloadgentoo-42e24662.tar.gz
gentoo-42e24662.tar.bz2
gentoo-42e24662.zip
dev-python/astroid-2.3.3: Version bump, add py38
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.86, Repoman-2.3.20 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--dev-python/astroid/Manifest1
-rw-r--r--dev-python/astroid/astroid-2.3.3.ebuild53
-rw-r--r--dev-python/astroid/files/astroid-2.3.3-no-pytest-runner.patch12
3 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/astroid/Manifest b/dev-python/astroid/Manifest
index c22c17e46844..32d62db68347 100644
--- a/dev-python/astroid/Manifest
+++ b/dev-python/astroid/Manifest
@@ -1,3 +1,4 @@
DIST astroid-1.4.8.tar.gz 184091 BLAKE2B 7180b98c757c8681dd0abaed1e79d2c58ce676aff07b539af8776d589ff23770335d0ba4ce5c9b3940b0428dd10174e7c6eff66aeb500e6ac561734e27975be0 SHA512 54bb20edf5518b417470a2d63210802b267fe727f9d30e1ac5000db00a7894739b1c4249468fb55df81b55d382f3a5bbe019876141f7ee4d94040fd699dc0c2c
DIST astroid-1.6.5.tar.gz 255688 BLAKE2B 7547e4c537f73ef77b61fba1ab8640c7cd50014ae52e4e4b8f8209a000c55bbdbb1ddcd3fb90d078f99a34d4a4779adabc8ad71af40c3a4547fe3e0d814b328c SHA512 f51f275c9f04809c8993d187cb62fadc84003ddc954d371356474dbe6b719868406fd9188c560f5b658b8b44bb6a4d3ee0785e809e789ca117e2bcbdb58aec53
DIST astroid-2.2.5.tar.gz 281829 BLAKE2B 2cc341caac381fb44b0302e8057a6e2105a6a82dbf807f8a59598e15c5658cc30d4c32e3b58ebbc94c4559f2b2274373f5ed6c4b86b4e8eff86dd91a5520e7ce SHA512 71c8c26314f666e2b9519a83dd9476fbfe0ad7d72f5308f6a94b83c5442dc695bc3e51155df45586ff2ff0eec522a02286d00ac566d542f0b82e5e0d0d7d9c65
+DIST astroid-2.3.3.tar.gz 297350 BLAKE2B 7ac5cf028fa0263998271d23128b1bfd127fedafab2f6b3cc465867b9668942e1edc79bed62eb34bcce31b6892e4c5a31dbdd68d20fb92a1f134dc9e78a76920 SHA512 72011f3eb312ea7ce7dd55f7615972f6bfc152d8f16f9052b405f44fe17e594d5da22e0502b4c3034881b9783be9e808509d4ded3d679182ddf6d34eb90748f1
diff --git a/dev-python/astroid/astroid-2.3.3.ebuild b/dev-python/astroid/astroid-2.3.3.ebuild
new file mode 100644
index 000000000000..bf9cf97da4d2
--- /dev/null
+++ b/dev-python/astroid/astroid-2.3.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Abstract Syntax Tree for logilab packages"
+HOMEPAGE="https://github.com/PyCQA/astroid https://pypi.org/project/astroid/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# Version specified in __pkginfo__.py.
+RDEPEND="
+ dev-python/lazy-object-proxy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/wrapt[${PYTHON_USEDEP}]
+ >=dev-python/typed-ast-1.3.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.3.3-no-pytest-runner.patch"
+)
+
+python_prepare_all() {
+ # Disable failing tests
+
+ # no idea why this test fails
+ sed -i -e "s/test_knownValues_get_builtin_module_part/_&/" \
+ astroid/tests/unittest_modutils.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${EPYTHON}" -m pytest -v --pyarg astroid/tests \
+ || die "tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/astroid/files/astroid-2.3.3-no-pytest-runner.patch b/dev-python/astroid/files/astroid-2.3.3-no-pytest-runner.patch
new file mode 100644
index 000000000000..5dd24f2e2c43
--- /dev/null
+++ b/dev-python/astroid/files/astroid-2.3.3-no-pytest-runner.patch
@@ -0,0 +1,12 @@
+diff --git a/setup.py b/setup.py
+index 439ceafa..2ad55d6b 100644
+--- a/setup.py
++++ b/setup.py
+@@ -43,7 +43,6 @@ def install():
+ install_requires=install_requires,
+ extras_require=extras_require,
+ packages=find_packages(exclude=["astroid.tests"]) + ["astroid.brain"],
+- setup_requires=["pytest-runner"],
+ test_suite="test",
+ tests_require=["pytest"],
+ )