summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-10-03 23:57:25 +0200
committerDavid Seifert <soap@gentoo.org>2021-10-03 23:57:25 +0200
commit43058137249b79b215d14190f62a5d66f14de21f (patch)
treedcac6a84afd68a4859e7db7aa8161606e7a69539
parentdev-util/devhelp: bump to 41.2 (diff)
downloadgentoo-43058137.tar.gz
gentoo-43058137.tar.bz2
gentoo-43058137.zip
net-fs/nfs-utils: Fix sasl/mit-krb5 automagic
Closes: https://bugs.gentoo.org/810592 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--net-fs/nfs-utils/nfs-utils-2.5.4-r1.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/net-fs/nfs-utils/nfs-utils-2.5.4-r1.ebuild b/net-fs/nfs-utils/nfs-utils-2.5.4-r1.ebuild
index 09b5abbe4c36..414117f1f15d 100644
--- a/net-fs/nfs-utils/nfs-utils-2.5.4-r1.ebuild
+++ b/net-fs/nfs-utils/nfs-utils-2.5.4-r1.ebuild
@@ -19,7 +19,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="caps ipv6 junction kerberos ldap +libmount nfsdcld +nfsidmap +nfsv4 nfsv41 selinux tcpd +uuid"
+IUSE="caps ipv6 junction kerberos ldap +libmount nfsdcld +nfsidmap +nfsv4 nfsv41 sasl selinux tcpd +uuid"
REQUIRED_USE="kerberos? ( nfsv4 )"
RESTRICT="test" #315573
@@ -34,7 +34,13 @@ DEPEND="
>=net-nds/rpcbind-0.2.4
sys-fs/e2fsprogs
caps? ( sys-libs/libcap )
- ldap? ( net-nds/openldap )
+ ldap? (
+ net-nds/openldap
+ sasl? (
+ app-crypt/mit-krb5
+ dev-libs/cyrus-sasl:2
+ )
+ )
libmount? ( sys-apps/util-linux )
nfsv4? (
dev-libs/libevent:=
@@ -88,6 +94,11 @@ src_prepare() {
src_configure() {
export libsqlite3_cv_is_recent=yes # Our DEPEND forces this.
export ac_cv_header_keyutils_h=$(usex nfsidmap)
+
+ # SASL is consumed in a purely automagic way
+ export ac_cv_header_sasl_h=no
+ export ac_cv_header_sasl_sasl_h=$(usex sasl)
+
local myeconfargs=(
--disable-static
--with-statedir="${EPREFIX}"/var/lib/nfs