summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-04-01 10:04:36 -0400
committerMike Gilbert <floppym@gentoo.org>2016-04-01 10:09:20 -0400
commit4473cfa41f7d013af8bf7d967ea5ceac773136eb (patch)
treec2f82e2898a2e89ccac0cf25a33ea32b0d13d6a0
parentdev-vcs/gitstats: force text processing by grep (diff)
downloadgentoo-4473cfa4.tar.gz
gentoo-4473cfa4.tar.bz2
gentoo-4473cfa4.zip
sys-apps/coreutils: Move kill to /bin per FHS
This also makes it consistent with procps and util-linux. Package-Manager: portage-2.2.28_p64
-rw-r--r--sys-apps/coreutils/coreutils-8.24.ebuild5
-rw-r--r--sys-apps/coreutils/coreutils-8.25.ebuild5
2 files changed, 8 insertions, 2 deletions
diff --git a/sys-apps/coreutils/coreutils-8.24.ebuild b/sys-apps/coreutils/coreutils-8.24.ebuild
index b350b0275b7e..bf3fac743354 100644
--- a/sys-apps/coreutils/coreutils-8.24.ebuild
+++ b/sys-apps/coreutils/coreutils-8.24.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -147,6 +147,9 @@ src_install() {
local fhs="cat chgrp chmod chown cp date dd df echo false ln ls
mkdir mknod mv pwd rm rmdir stty sync true uname"
mv ${fhs} ../../bin/ || die "could not move fhs bins"
+ if use kill; then
+ mv kill ../../bin/ || die
+ fi
# move critical binaries into /bin (common scripts)
local com="basename chroot cut dir dirname du env expr head mkfifo
mktemp readlink seq sleep sort tail touch tr tty vdir wc yes"
diff --git a/sys-apps/coreutils/coreutils-8.25.ebuild b/sys-apps/coreutils/coreutils-8.25.ebuild
index 4e858f968faf..706651c59b3b 100644
--- a/sys-apps/coreutils/coreutils-8.25.ebuild
+++ b/sys-apps/coreutils/coreutils-8.25.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -147,6 +147,9 @@ src_install() {
local fhs="cat chgrp chmod chown cp date dd df echo false ln ls
mkdir mknod mv pwd rm rmdir stty sync true uname"
mv ${fhs} ../../bin/ || die "could not move fhs bins"
+ if use kill; then
+ mv kill ../../bin/ || die
+ fi
# move critical binaries into /bin (common scripts)
local com="basename chroot cut dir dirname du env expr head mkfifo
mktemp readlink seq sleep sort tail touch tr tty vdir wc yes"