summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-02 11:05:32 +0000
committerSam James <sam@gentoo.org>2021-01-02 11:10:58 +0000
commit455cc21abfbef1f0eb76dc8e81532fda7a9d4699 (patch)
tree2fc7ffd991ae481b2ca101451f7a045e8ca6ca09
parentnet-analyzer/fail2ban: minor style changes to 9999 (diff)
downloadgentoo-455cc21a.tar.gz
gentoo-455cc21a.tar.bz2
gentoo-455cc21a.zip
net-analyzer/mtr: style changes
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-analyzer/mtr/mtr-0.94.ebuild16
-rw-r--r--net-analyzer/mtr/mtr-9999.ebuild17
2 files changed, 16 insertions, 17 deletions
diff --git a/net-analyzer/mtr/mtr-0.94.ebuild b/net-analyzer/mtr/mtr-0.94.ebuild
index 7f9e0050a0cb..f8246b2632f8 100644
--- a/net-analyzer/mtr/mtr-0.94.ebuild
+++ b/net-analyzer/mtr/mtr-0.94.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit autotools bash-completion-r1 fcaps
DESCRIPTION="My TraceRoute, an Excellent network diagnostic tool"
@@ -12,6 +13,8 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="gtk +ipinfo +ipv6 jansson ncurses"
+# This is an inherited RESTRICT - figure out why!
+RESTRICT="test"
RDEPEND="
gtk? (
@@ -21,18 +24,15 @@ RDEPEND="
jansson? ( dev-libs/jansson )
ncurses? ( sys-libs/ncurses:0= )
"
-DEPEND="
- ${RDEPEND}
-"
-BDEPEND="
- virtual/pkgconfig
-"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
DOCS=( AUTHORS FORMATS NEWS README.md SECURITY TODO )
FILECAPS=( cap_net_raw usr/sbin/mtr-packet )
+
PATCHES=(
"${FILESDIR}"/${PN}-0.88-tinfo.patch
)
-RESTRICT="test"
src_prepare() {
default
diff --git a/net-analyzer/mtr/mtr-9999.ebuild b/net-analyzer/mtr/mtr-9999.ebuild
index 7067fbb688f5..bf0d00068f92 100644
--- a/net-analyzer/mtr/mtr-9999.ebuild
+++ b/net-analyzer/mtr/mtr-9999.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit autotools bash-completion-r1 fcaps git-r3
DESCRIPTION="My TraceRoute, an Excellent network diagnostic tool"
@@ -10,8 +11,9 @@ EGIT_REPO_URI="https://github.com/traviscross/mtr"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS=""
IUSE="gtk +ipinfo +ipv6 jansson ncurses"
+# TODO: This is an inherited RESTRICT - figure out why!
+RESTRICT="test"
RDEPEND="
gtk? (
@@ -21,18 +23,15 @@ RDEPEND="
jansson? ( dev-libs/jansson )
ncurses? ( sys-libs/ncurses:0= )
"
-DEPEND="
- ${RDEPEND}
-"
-BDEPEND="
- virtual/pkgconfig
-"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
DOCS=( AUTHORS FORMATS NEWS README.md SECURITY TODO )
FILECAPS=( cap_net_raw usr/sbin/mtr-packet )
+
PATCHES=(
"${FILESDIR}"/${PN}-0.88-tinfo.patch
)
-RESTRICT="test"
src_prepare() {
default