summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-01 09:53:38 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-01 11:31:57 +0100
commit482a2afdad62f7ea7674823b8c3af8593d4ddefb (patch)
treeb53d79ef7113fe8b8f569625cff29bf82b91c0d6
parentdev-python/cmd2: Remove unnecessary dift (diff)
downloadgentoo-482a2afd.tar.gz
gentoo-482a2afd.tar.bz2
gentoo-482a2afd.zip
dev-python/asn1crypto: Bump to 1.4.0
Closes: https://bugs.gentoo.org/757786 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/asn1crypto/Manifest1
-rw-r--r--dev-python/asn1crypto/asn1crypto-1.4.0.ebuild20
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/asn1crypto/Manifest b/dev-python/asn1crypto/Manifest
index b06a9580e239..e5efbfd9097f 100644
--- a/dev-python/asn1crypto/Manifest
+++ b/dev-python/asn1crypto/Manifest
@@ -1 +1,2 @@
DIST asn1crypto-0.24.0.gh.tar.gz 641322 BLAKE2B eb30afd0d2579f44ee4f556139357dc7622691bdc2067df913a4412cd3dca8372b85d84e3a3cbef6ba83648bf4ef55d7e8614992e2abb019301c92d24b15a926 SHA512 426cc380903b4dd7aadd7b831e3a11ee3442c961a33b856d4aa8d9060e829f2e0ad905a60c4d6504569718fe2cee01d9be31628c89ef030bc34281e381c898e8
+DIST asn1crypto-1.4.0.gh.tar.gz 672812 BLAKE2B 7545d424c244c04c2639df45e0bb56c50de95d0a7ee1e56933720dd7215c2be2608ac7889e2e901785592592e9ac6cb116fff3cd00536903c392a9e3912fc08a SHA512 989e4e0650252c29477d71263549b99f2c51c87f0768c20264b3de65f32edd8e7922e8af23bb1a7e29567a4ad8c4c5d596cdf7db3c766352c7f19d4f93361cd0
diff --git a/dev-python/asn1crypto/asn1crypto-1.4.0.ebuild b/dev-python/asn1crypto/asn1crypto-1.4.0.ebuild
new file mode 100644
index 000000000000..9803ec895c27
--- /dev/null
+++ b/dev-python/asn1crypto/asn1crypto-1.4.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python ASN.1 library with a focus on performance and a pythonic API"
+HOMEPAGE="https://github.com/wbond/asn1crypto/ https://pypi.org/project/asn1crypto/"
+# pypi tarball does not have tests
+SRC_URI="https://github.com/wbond/asn1crypto/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+distutils_enable_tests unittest