summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2017-01-07 16:38:57 -0500
committerGöktürk Yüksek <gokturk@gentoo.org>2017-01-07 16:42:04 -0500
commit48487f9a0bdc6786740f80541c2230c8de257bcc (patch)
treee572e5a643d27730c6c13e9d8b83175989988878
parentnet-misc/openssh: Use pkg_pretend() to detect earlier unsupported features (diff)
downloadgentoo-48487f9a0bdc6786740f80541c2230c8de257bcc.tar.gz
gentoo-48487f9a0bdc6786740f80541c2230c8de257bcc.tar.bz2
gentoo-48487f9a0bdc6786740f80541c2230c8de257bcc.zip
x11-plugins/pidgintex: bump to 1.1.2_p20170107
Package-Manager: portage-2.3.0
-rw-r--r--x11-plugins/pidgintex/Manifest1
-rw-r--r--x11-plugins/pidgintex/pidgintex-1.1.2_p20170107.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/x11-plugins/pidgintex/Manifest b/x11-plugins/pidgintex/Manifest
index 9db928d7c391..501c65f0e130 100644
--- a/x11-plugins/pidgintex/Manifest
+++ b/x11-plugins/pidgintex/Manifest
@@ -1 +1,2 @@
DIST pidginTeX-1.1.1.tar.gz 23322 SHA256 1b47e89d12d5f5a8de4f3f89ea37da393223d525632c92e71cef8a54399ac1aa SHA512 df58e783cc19d5aa5a57dcb337192d593ad8427a860fd0314bf3f1fe0ca248e92ef8f675cd344c5703319ecfb91f88ea88e6917b8f4c89bf92dc45dd53015bb8 WHIRLPOOL 735734a62f140eb6fa704b310f829c11899a1ea44784589f120e9e63f31b905a2b0c900637cf1df393fc3fe77f07cec33f901e412635d6de30de40fd66c0b743
+DIST pidgintex-1.1.2_p20170107.tar.gz 50671 SHA256 48c79474aa5c41270756022a481935b0f4321380c2e58455cc42369e48cc1d59 SHA512 fbbe6eb4e2a0a5c9086e65d967133ab1cdd09292ce0b0cc474b82fbbcfc6b9abbb49ed3828c8e7094b7fef629a372833ec6f143ed4eb1b7d5c4fbd32e98a0271 WHIRLPOOL a61e27562e879de12ecd7a3a295c4d22169e2863c0e551b16940330372cee116b0e6818f775b46ea0143114005df0c1d632c370cf633b068165b8904c83da631
diff --git a/x11-plugins/pidgintex/pidgintex-1.1.2_p20170107.ebuild b/x11-plugins/pidgintex/pidgintex-1.1.2_p20170107.ebuild
new file mode 100644
index 000000000000..49c962ecc8be
--- /dev/null
+++ b/x11-plugins/pidgintex/pidgintex-1.1.2_p20170107.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit toolchain-funcs vcs-snapshot
+
+MY_COMMIT_HASH="a8f618cf1bf92279b43c7b737010fd7e42c8e5d3"
+
+DESCRIPTION="Pidgin plugin to render LaTeX expressions in messages"
+HOMEPAGE="https://github.com/Micket/pidgintex"
+SRC_URI="https://github.com/Micket/${PN}/archive/${MY_COMMIT_HASH}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="net-im/pidgin[gtk]
+ app-text/mathtex
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -e "s:\(^CC.*=\).*:\1 $(tc-getCC):" \
+ -e "s:\(^STRIP.*=\).*:\1 true:" \
+ -e "s:\(^CFLAGS[[:space:]]*\)=:\1+=:" \
+ -e "/LIB_INSTALL_DIR/{s:/lib/purple-2:/$(get_libdir)/pidgin:;}" \
+ -i Makefile || die
+ # set default renderer to mathtex
+ sed -e "/purple_prefs_add_string.*PREFS_RENDERER/{s:mimetex:mathtex:;}" \
+ -i pidginTeX.c || die
+
+ if ! use nls; then
+ sed -e '/ENABLE_NLS = 1/ d;' -i Makefile || die
+ fi
+
+ default
+}
+
+src_compile() {
+ emake PREFIX=/usr
+}
+
+src_install() {
+ emake PREFIX="${ED%/}/usr" install
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog 'Note, to see formulas either disable "Conversation Colors" plugin or'
+ elog 'switch off "ignore incoming format" option in plugin configuration.'
+ elog 'For details, take a look (and vote) at http://developer.pidgin.im/ticket/2772'
+}