summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-10-07 06:54:13 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-10-07 20:24:01 +0300
commit496d5c8168056d13ec03b9d9303a6213d9da4361 (patch)
tree5dfb2f8e467de4ce67fa20558e493154f608bb3d
parentdev-libs/level-zero: bump to version 1.5.4 (diff)
downloadgentoo-496d5c8168056d13ec03b9d9303a6213d9da4361.tar.gz
gentoo-496d5c8168056d13ec03b9d9303a6213d9da4361.tar.bz2
gentoo-496d5c8168056d13ec03b9d9303a6213d9da4361.zip
dev-python/casttube: add 0.2.1, enable py3.10
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/casttube/Manifest1
-rw-r--r--dev-python/casttube/casttube-0.2.1.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/casttube/Manifest b/dev-python/casttube/Manifest
index 13383348e09d..8087824be758 100644
--- a/dev-python/casttube/Manifest
+++ b/dev-python/casttube/Manifest
@@ -1 +1,2 @@
DIST casttube-0.2.0.tar.gz 3760 BLAKE2B d4e37fb0e98f2e9197e7e1a78b45109d0319f9b4337ef86d0dcd5797e703960162432990b9c4d26796ce5cc957179023044b86a9b07c8e581d13373889c6c824 SHA512 0ab69a92d49a9095c0adb70fec95011447d1f2a57e7642504d2ab4f19fc5f93b09db0e5d277bf7876311e5f26067a687bde58e3aa12469dcc6778486fc19c836
+DIST casttube-0.2.1.tar.gz 5182 BLAKE2B 0cd279da67aa59ddaa82913ef40815d28884b078448804742dfa3a6242a666c86cdaecf30cdf1ea913188d61953b5f38e133311d11491db443b55ae78b186558 SHA512 0b077b1f622c1029e9cff949a1d1cd4f380d9110324ca6211eb4d6bc97fbf3aa4d7be47cb692c2a7628ab62b309fd9957ee6392060f27e06d030691ad8cde00f
diff --git a/dev-python/casttube/casttube-0.2.1.ebuild b/dev-python/casttube/casttube-0.2.1.ebuild
new file mode 100644
index 000000000000..db1f1d648330
--- /dev/null
+++ b/dev-python/casttube/casttube-0.2.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="casttube provides a way to interact with the Youtube Chromecast api."
+HOMEPAGE="https://github.com/ur1katz/casttube"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/requests[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ sed -e '/data_files/d' -i setup.py || die
+ distutils-r1_src_prepare
+}