summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-03-01 22:02:40 +0100
committerPatrick Lauer <patrick@gentoo.org>2016-03-01 23:36:27 +0100
commit4a148651d39c5e8fd2b188f8c1b2775362b3dc69 (patch)
tree9bff799ca5df34cffd5cffe09e8343b42d0ed4d8
parentdev-python/mimerender: Bump (diff)
downloadgentoo-4a148651.tar.gz
gentoo-4a148651.tar.bz2
gentoo-4a148651.zip
dev-python/waitress: Bump
Package-Manager: portage-2.2.27
-rw-r--r--dev-python/waitress/Manifest1
-rw-r--r--dev-python/waitress/waitress-0.8.10.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/waitress/Manifest b/dev-python/waitress/Manifest
index 9954de7eef75..3019f75fc26f 100644
--- a/dev-python/waitress/Manifest
+++ b/dev-python/waitress/Manifest
@@ -1,2 +1,3 @@
DIST pylons_sphinx_theme.tar.gz 607608 SHA256 d892c80fbee8845b79cb41845a89cf2f268893689a68157bc10bd0224948bb9c SHA512 fdafd77e52ff6941de5102bad521ed2a9e28cff6be385cab660a7604be12fa1d86db73fc93f84f72551458cc60b42d3354f27648b1d747b15b25d6f809df8a4d WHIRLPOOL bcf8329b35b90d65eae86a8fc910d074790f912cfe7d4bdd9065970f5c24344e57e585d8dd0b28f101b4ddd4ed0b65caa3bdf7c93fb933ddc6916e63514fa69f
+DIST waitress-0.8.10.tar.gz 123717 SHA256 7c40c1af0f0c254edb25153621a1e825bc1af2f7bf41a74b4bb8ee6d544ef604 SHA512 ba9e418c8cb7094e446b636a98c0d714eacdfd0643f4bd8b99e59cb0f9a56a9538b713482dd830ae5d3ace0381fe75521501ddd979fe5e292645fbf725cf7fe1 WHIRLPOOL 49e55034bdf203aadb07b9c9bce36a1fbd25f45f1cc6da70bd89d5eed8cb6bc1c1cef8b9b82ef21ef9bb724b2eb8c56d004dcba7a8abda98578cb6e3c617589b
DIST waitress-0.8.9.tar.gz 121048 SHA256 826527dc9d334ed4ed76cdae672fdcbbccf614186657db71679ab58df869458a SHA512 e9459b8806389fcdbd6f7cfc4fc908c2076f1fcc306315c5375c872c1a0c43c2537347322f7becf1ad36aec0050dca7b2f713f35318fe3a371e544cc880b7d8c WHIRLPOOL f3ce347d3fa04944ebcf7b6b3734bed0ff1fb1fc1dd9479a10cc4cc77111ae250e2c652dd195b15a86c1c7b740d751d0ca539791f3b97c942737ca0be033a59a
diff --git a/dev-python/waitress/waitress-0.8.10.ebuild b/dev-python/waitress/waitress-0.8.10.ebuild
new file mode 100644
index 000000000000..c9fe158908cb
--- /dev/null
+++ b/dev-python/waitress/waitress-0.8.10.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure-Python WSGI server"
+HOMEPAGE="http://docs.pylonsproject.org/projects/waitress/en/latest/ https://pypi.python.org/pypi/waitress/ https://github.com/Pylons/waitress"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz \
+ doc? ( https://dev.gentoo.org/~idella4/pylons_sphinx_theme.tar.gz )"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ if use doc; then
+ local PATCHES=( "${FILESDIR}"/${P}-doc.patch )
+ mv "${WORKDIR}"/_themes ./docs/ || die
+ fi
+
+ # Fix generation of documentation with Waitress not installed. Bug #525384
+ sed -e "s/^version = pkg_resources.get_distribution('waitress').version$/version = '${PV}'/" -i docs/conf.py
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}