summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-11 04:32:51 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-11 05:14:23 +0200
commit4b0eb1d39f051930f49926ea8437a720bce23a73 (patch)
tree40d404b804a84e45ba940d76837101eb949e1965
parentdev-python/cfn-lint: Bump to 0.77.0 (diff)
downloadgentoo-4b0eb1d39f051930f49926ea8437a720bce23a73.tar.gz
gentoo-4b0eb1d39f051930f49926ea8437a720bce23a73.tar.bz2
gentoo-4b0eb1d39f051930f49926ea8437a720bce23a73.zip
dev-python/tempora: Bump to 5.2.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/tempora/Manifest1
-rw-r--r--dev-python/tempora/tempora-5.2.2.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/tempora/Manifest b/dev-python/tempora/Manifest
index e7d30099fc19..4525bde87c78 100644
--- a/dev-python/tempora/Manifest
+++ b/dev-python/tempora/Manifest
@@ -1 +1,2 @@
DIST tempora-5.2.1.tar.gz 20787 BLAKE2B 67e9bf07e79dca0f31b6558824ab54fe2cab0556e7fddbac0e0e61c863eff0e0f0c4d6162a2856cf05b4ca9bedef1440811330638cb2f94d2c5e140c4b6401e3 SHA512 18e352bfa82ac81dac26907a6bcc5e68c018410a9cfc7a1b4d6d8609c1a6a35fb3be3c374449109ed5c32b679c3835aa31d2ce0dc814d3697e6f7f5c6976eefe
+DIST tempora-5.2.2.tar.gz 20957 BLAKE2B f8463e544534c0d90bc90da7ed2a829a7afeba54b9c8f21cb831680caba493075b58544560a940d2449e4c9e4803be62413ea1029ee0ce80772ab212ff84a13e SHA512 2031f9ddca66fb0aa93aa1e1162450a3a14e17c41acd19fc657f3c0cd0c058487c9b1377c9f319b15c7f3c39393d184eabfa62038d0493fc3808b6557dfee2cb
diff --git a/dev-python/tempora/tempora-5.2.2.ebuild b/dev-python/tempora/tempora-5.2.2.ebuild
new file mode 100644
index 000000000000..dca7d962b13e
--- /dev/null
+++ b/dev-python/tempora/tempora-5.2.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Objects and routines pertaining to date and time"
+HOMEPAGE="https://github.com/jaraco/tempora"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/jaraco-functools-1.20[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pytest-freezegun[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest