summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2024-03-23 15:37:55 -0400
committerMike Gilbert <floppym@gentoo.org>2024-03-23 15:57:44 -0400
commit4eb56bda286f2d845477a287d1c69ef1c339b7dd (patch)
tree11dd823cb550d5ded042d12ec63673c0b53ce981
parentpackage.mask: Last rite dev-python/prov (diff)
downloadgentoo-4eb56bda286f2d845477a287d1c69ef1c339b7dd.tar.gz
gentoo-4eb56bda286f2d845477a287d1c69ef1c339b7dd.tar.bz2
gentoo-4eb56bda286f2d845477a287d1c69ef1c339b7dd.zip
sys-apps/systemd-utils: fix kernel-install logic
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
-rw-r--r--sys-apps/systemd-utils/systemd-utils-254.10.ebuild8
-rw-r--r--sys-apps/systemd-utils/systemd-utils-254.8.ebuild8
2 files changed, 8 insertions, 8 deletions
diff --git a/sys-apps/systemd-utils/systemd-utils-254.10.ebuild b/sys-apps/systemd-utils/systemd-utils-254.10.ebuild
index e0ac974de10f..93436b880f05 100644
--- a/sys-apps/systemd-utils/systemd-utils-254.10.ebuild
+++ b/sys-apps/systemd-utils/systemd-utils-254.10.ebuild
@@ -446,8 +446,6 @@ multilib_src_install() {
if use kernel-install; then
dobin kernel-install
doman man/kernel-install.8
- # copy the default set of plugins
- cp "${S}/src/kernel-install/"*.install src/kernel-install || die
exeinto usr/lib/kernel/install.d
doexe src/kernel-install/*.install
fi
@@ -503,12 +501,14 @@ multilib_src_install_all() {
einstalldocs
if use boot; then
into /usr
- exeinto usr/lib/kernel/install.d
- doexe src/kernel-install/*.install
dobashcomp shell-completion/bash/bootctl
insinto /usr/share/zsh/site-functions
doins shell-completion/zsh/{_bootctl,_kernel-install}
fi
+ if use kernel-install; then
+ exeinto usr/lib/kernel/install.d
+ doexe src/kernel-install/*.install
+ fi
if use tmpfiles; then
doinitd "${FILESDIR}"/systemd-tmpfiles-setup
doinitd "${FILESDIR}"/systemd-tmpfiles-setup-dev
diff --git a/sys-apps/systemd-utils/systemd-utils-254.8.ebuild b/sys-apps/systemd-utils/systemd-utils-254.8.ebuild
index af0e5dfe3c6a..b73e1d640a89 100644
--- a/sys-apps/systemd-utils/systemd-utils-254.8.ebuild
+++ b/sys-apps/systemd-utils/systemd-utils-254.8.ebuild
@@ -446,8 +446,6 @@ multilib_src_install() {
if use kernel-install; then
dobin kernel-install
doman man/kernel-install.8
- # copy the default set of plugins
- cp "${S}/src/kernel-install/"*.install src/kernel-install || die
exeinto usr/lib/kernel/install.d
doexe src/kernel-install/*.install
fi
@@ -504,12 +502,14 @@ multilib_src_install_all() {
einstalldocs
if use boot; then
into /usr
- exeinto usr/lib/kernel/install.d
- doexe src/kernel-install/*.install
dobashcomp shell-completion/bash/bootctl
insinto /usr/share/zsh/site-functions
doins shell-completion/zsh/{_bootctl,_kernel-install}
fi
+ if use kernel-install; then
+ exeinto usr/lib/kernel/install.d
+ doexe src/kernel-install/*.install
+ fi
if use tmpfiles; then
doinitd "${FILESDIR}"/systemd-tmpfiles-setup
doinitd "${FILESDIR}"/systemd-tmpfiles-setup-dev