summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-01 15:40:44 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-01 15:40:44 +0200
commit4fcf2dc2b4dd908faa969e0cd3aa8aeddd47dcb8 (patch)
tree59532c715d2ae606ee6cce365b6604765ba0cd0c
parentdev-python/cbor2: Bump to 5.4.2_p1 (diff)
downloadgentoo-4fcf2dc2.tar.gz
gentoo-4fcf2dc2.tar.bz2
gentoo-4fcf2dc2.zip
dev-python/cheetah3: Bump to 3.2.6_p2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/cheetah3/Manifest1
-rw-r--r--dev-python/cheetah3/cheetah3-3.2.6_p2.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/cheetah3/Manifest b/dev-python/cheetah3/Manifest
index d2a51d68201b..285b32d7ef70 100644
--- a/dev-python/cheetah3/Manifest
+++ b/dev-python/cheetah3/Manifest
@@ -1 +1,2 @@
+DIST cheetah3-3.2.6.post2.tar.gz 316291 BLAKE2B d5dfaa958bc0cc41097d4a75abfe092d51379efd644daa01caac6ba1b789c21334a662904166b6069a0204e302c1d9e7bea74aa9f11082b9c8fce1c1c509f888 SHA512 b10d2569ce92181029b8f95d23602ec7b002400c8fdf4f6bb095ff40201154b97418fec19c9920f2f212f545633571aa32dc50a16a9ba81a9427303ca7938f29
DIST cheetah3-3.2.6.tar.gz 2481158 BLAKE2B cb8ad192ae9caf0d1284294b323cf4a918cd2fc951bae25867d69a3dd7933728056b76fbf52a22d34f290056a96cce7d9ccbeb2404f2f0bb782f8db8b7453e47 SHA512 abf74def695018a79cb1364f60e402e7e0095a4d2f069decfbddf42501d865b70451ebc7b52abc67aa23e57276d7a3b8c2894a9571876e15db43cd1358f74d31
diff --git a/dev-python/cheetah3/cheetah3-3.2.6_p2.ebuild b/dev-python/cheetah3/cheetah3-3.2.6_p2.ebuild
new file mode 100644
index 000000000000..a4c89574fcc1
--- /dev/null
+++ b/dev-python/cheetah3/cheetah3-3.2.6_p2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P=${P/_p/.post}
+DESCRIPTION="Python-powered template engine and code generator"
+HOMEPAGE="https://cheetahtemplate.org/ https://pypi.org/project/Cheetah3/"
+SRC_URI="
+ https://github.com/CheetahTemplate3/${PN}/archive/${PV/_p/.post}.tar.gz
+ -> ${MY_P}.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+SLOT="0"
+
+RDEPEND="
+ dev-python/markdown[${PYTHON_USEDEP}]
+ !dev-python/cheetah
+"
+BDEPEND="${RDEPEND}"
+
+DOCS=( ANNOUNCE.rst README.rst TODO )
+
+python_prepare_all() {
+ # Disable broken tests.
+ sed -i -e "/Unicode/d" -i Cheetah/Tests/Test.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${EPYTHON}" Cheetah/Tests/Test.py || die "Tests fail with ${EPYTHON}"
+}