summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2023-04-02 14:05:11 +0300
committerViorel Munteanu <ceamac@gentoo.org>2023-04-02 14:05:11 +0300
commit530ba430bf5b8b79a6003a99adfdc9dde15378e4 (patch)
tree7de1c648b7adbbaa58997e5412bca12bca5d93d4
parentapp-text/xapian-omega: add 1.4.22 (diff)
downloadgentoo-530ba430bf5b8b79a6003a99adfdc9dde15378e4.tar.gz
gentoo-530ba430bf5b8b79a6003a99adfdc9dde15378e4.tar.bz2
gentoo-530ba430bf5b8b79a6003a99adfdc9dde15378e4.zip
www-apps/roundup: add 2.2.0
Closes: https://bugs.gentoo.org/897332 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
-rw-r--r--www-apps/roundup/Manifest1
-rw-r--r--www-apps/roundup/roundup-2.2.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/www-apps/roundup/Manifest b/www-apps/roundup/Manifest
index f0804e5b918f..4eca53c9974b 100644
--- a/www-apps/roundup/Manifest
+++ b/www-apps/roundup/Manifest
@@ -1,2 +1,3 @@
DIST roundup-2.0.0.tar.gz 3495554 BLAKE2B 98b7cbfebe969411282ddf6b4bd7b94ea1efb7b1d929daf44ae5f30dc23c05cb327d0f4653b22a5594f7b198dd16a172c45568a15f8704b187cd4c355455ca9c SHA512 5adb0d96be260e70fe098fd37af27bd0abee38cb8fde4ba2e130d2caac7f64af86a3b0ab09de931a693dca8bfbe15c68444db343ccf718d9d25576d49c6d6cbf
DIST roundup-2.1.0.tar.gz 3586805 BLAKE2B a5ec6cad38e252e2ffd4d3de4def9b8414ee8758503aa29681d80b36ac62a15700e21e762c6833ce6f795f71a7a1c75c4d9ae30c49c5f038317e5d3fdc58b11d SHA512 ebc047d944f1118b30141b873d91e580d415f1e7c9331875d6efb18cf42c9121163c801b1559d02890165bfd2e5a894c5990b587ce7766b2bf4724745ca9e760
+DIST roundup-2.2.0.tar.gz 3722236 BLAKE2B f9f36ff2a49c769dcce38dd59fd88825cb3a6560fbfc2a7bbf6d2abf1388bb328da5aa7de2934ae2469163bb4f125b4438b07f1eff9082458768012b4eda7687 SHA512 dbaf7c4a5e7fb75f0e401f39962c8f5a3b088036a0f2c9efb2910f3941df35df6c345c2051c37cbdcc9a2049d82d09bcb4e15b368f8c4c77fa4b4bf80c6dc844
diff --git a/www-apps/roundup/roundup-2.2.0.ebuild b/www-apps/roundup/roundup-2.2.0.ebuild
new file mode 100644
index 000000000000..3348a3a9aa19
--- /dev/null
+++ b/www-apps/roundup/roundup-2.2.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Issue-tracking system with command-line, web, and e-mail interfaces"
+HOMEPAGE="https://roundup.sourceforge.io https://pypi.org/project/roundup/"
+
+LICENSE="MIT ZPL"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="+tz sqlite mysql postgres xapian whoosh ssl jinja pyjwt markdown"
+
+RDEPEND="
+ jinja? ( dev-python/jinja[$PYTHON_USEDEP] )
+ markdown? (
+ || (
+ dev-python/markdown[$PYTHON_USEDEP]
+ dev-python/markdown2[$PYTHON_USEDEP]
+ dev-python/mistune[$PYTHON_USEDEP]
+ )
+ )
+ mysql? ( dev-python/mysqlclient[$PYTHON_USEDEP] )
+ postgres? ( >=dev-python/psycopg-2.8:2[$PYTHON_USEDEP] )
+ pyjwt? ( dev-python/pyjwt[$PYTHON_USEDEP] )
+ sqlite? ( $(python_gen_impl_dep sqlite) )
+ ssl? ( dev-python/pyopenssl[$PYTHON_USEDEP] )
+ tz? ( dev-python/pytz[$PYTHON_USEDEP] )
+ whoosh? ( >=dev-python/whoosh-2.5.7[$PYTHON_USEDEP] )
+ xapian? ( >=dev-libs/xapian-bindings-1.0.0[python,$PYTHON_USEDEP] )
+"
+
+DOCS="CHANGES.txt doc/*.txt"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # this test fails (for both py3.10 and py3.11, and it also fails in 2.1.0)
+ # upstream report https://issues.roundup-tracker.org/issue2551272
+ test/test_templating.py::Markdown2TestCase::test_string_markdown_code_block_attribute
+)
+
+python_install_all() {
+ distutils-r1_python_install_all
+ mv "${ED}"/usr/share/doc/${PN}/html "${ED}"/usr/share/doc/${PF}/ || die
+ rmdir "${ED}"/usr/share/doc/${PN} || die
+}
+
+pkg_postinst() {
+ ewarn "See installation.txt for initialisation instructions."
+ ewarn "See upgrading.txt for upgrading instructions."
+}