summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-02-27 00:58:48 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-02-27 01:05:27 +0100
commit58407ede38ac6bfc6219475dc8ed8df0c9a1a653 (patch)
treedcca7b22734627b7616f574f37f404394a648dcf
parentapp-emacs/pymacs: enable python 3.11 (diff)
downloadgentoo-58407ede38ac6bfc6219475dc8ed8df0c9a1a653.tar.gz
gentoo-58407ede38ac6bfc6219475dc8ed8df0c9a1a653.tar.bz2
gentoo-58407ede38ac6bfc6219475dc8ed8df0c9a1a653.zip
app-emacs/treemacs: enable python 3.11
Closes: https://bugs.gentoo.org/896538 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-emacs/treemacs/treemacs-2.10-r2.ebuild7
-rw-r--r--app-emacs/treemacs/treemacs-2.9.5-r2.ebuild7
-rw-r--r--app-emacs/treemacs/treemacs-3.0-r1.ebuild7
3 files changed, 12 insertions, 9 deletions
diff --git a/app-emacs/treemacs/treemacs-2.10-r2.ebuild b/app-emacs/treemacs/treemacs-2.10-r2.ebuild
index 21707f71d5e4..de552c5b30b2 100644
--- a/app-emacs/treemacs/treemacs-2.10-r2.ebuild
+++ b/app-emacs/treemacs/treemacs-2.10-r2.ebuild
@@ -5,7 +5,7 @@ EAPI=8
NEED_EMACS=26.1
DISTUTILS_USE_PEP517=no
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit elisp distutils-r1
@@ -34,14 +34,14 @@ BDEPEND="
test? ( app-emacs/buttercup )
"
-DOCS=( Changelog.org Extensions.org README.org screenshots )
+BYTECOMPFLAGS="-L . -L src/elisp"
PATCHES=(
"${FILESDIR}"/${PN}-2.9.5-tests.patch
"${FILESDIR}"/${PN}-async-scripts.patch
"${FILESDIR}"/${PN}-icons-icon-directory.patch
)
-BYTECOMPFLAGS="-L . -L src/elisp"
+DOCS=( Changelog.org Extensions.org README.org screenshots )
SITEFILE="50${PN}-gentoo.el"
src_prepare() {
@@ -58,6 +58,7 @@ python_compile() {
src_compile() {
distutils-r1_src_compile
+
elisp-compile src/elisp/*.el
}
diff --git a/app-emacs/treemacs/treemacs-2.9.5-r2.ebuild b/app-emacs/treemacs/treemacs-2.9.5-r2.ebuild
index 847fece21ce8..1c2b01c56dc4 100644
--- a/app-emacs/treemacs/treemacs-2.9.5-r2.ebuild
+++ b/app-emacs/treemacs/treemacs-2.9.5-r2.ebuild
@@ -5,7 +5,7 @@ EAPI=8
NEED_EMACS=26.1
DISTUTILS_USE_PEP517=no
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit elisp distutils-r1
@@ -34,14 +34,14 @@ BDEPEND="
test? ( app-emacs/buttercup )
"
-DOCS=( Changelog.org Extensions.org README.org screenshots )
+BYTECOMPFLAGS="-L . -L src/elisp"
PATCHES=(
"${FILESDIR}"/${PN}-async-scripts.patch
"${FILESDIR}"/${PN}-icons-icon-directory.patch
"${FILESDIR}"/${P}-tests.patch
)
-BYTECOMPFLAGS="-L . -L src/elisp"
+DOCS=( Changelog.org Extensions.org README.org screenshots )
SITEFILE="50${PN}-gentoo.el"
src_prepare() {
@@ -58,6 +58,7 @@ python_compile() {
src_compile() {
distutils-r1_src_compile
+
elisp-compile src/elisp/*.el
}
diff --git a/app-emacs/treemacs/treemacs-3.0-r1.ebuild b/app-emacs/treemacs/treemacs-3.0-r1.ebuild
index 5b225323539c..2a86b46185ac 100644
--- a/app-emacs/treemacs/treemacs-3.0-r1.ebuild
+++ b/app-emacs/treemacs/treemacs-3.0-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=8
NEED_EMACS=26.1
DISTUTILS_USE_PEP517=no
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit elisp distutils-r1
@@ -34,7 +34,7 @@ BDEPEND="
test? ( app-emacs/buttercup )
"
-DOCS=( Changelog.org Extensions.org README.org screenshots )
+BYTECOMPFLAGS="-L . -L src/elisp"
PATCHES=(
"${FILESDIR}"/${PN}-2.9.5-tests.patch
"${FILESDIR}"/${PN}-async-scripts.patch
@@ -42,7 +42,7 @@ PATCHES=(
"${FILESDIR}"/${P}-tests.patch
)
-BYTECOMPFLAGS="-L . -L src/elisp"
+DOCS=( Changelog.org Extensions.org README.org screenshots )
SITEFILE="50${PN}-gentoo.el"
src_prepare() {
@@ -59,6 +59,7 @@ python_compile() {
src_compile() {
distutils-r1_src_compile
+
elisp-compile src/elisp/*.el
}