summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-08-22 22:29:50 +0100
committerMarek Szuba <marecki@gentoo.org>2023-08-22 22:35:32 +0100
commit58d5352e7310e2f37dd2e8e458123d8a05746f6a (patch)
tree010892936f1811df241512df530469923ed29aff
parentapp-misc/gramps: drop 5.1.5 (diff)
downloadgentoo-58d5352e7310e2f37dd2e8e458123d8a05746f6a.tar.gz
gentoo-58d5352e7310e2f37dd2e8e458123d8a05746f6a.tar.bz2
gentoo-58d5352e7310e2f37dd2e8e458123d8a05746f6a.zip
dev-cpp/benchmark: drop 1.7.1, 1.8.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--dev-cpp/benchmark/Manifest2
-rw-r--r--dev-cpp/benchmark/benchmark-1.7.1.ebuild36
-rw-r--r--dev-cpp/benchmark/benchmark-1.8.0.ebuild36
3 files changed, 0 insertions, 74 deletions
diff --git a/dev-cpp/benchmark/Manifest b/dev-cpp/benchmark/Manifest
index 4fe08f538e6e..1169e1cbc249 100644
--- a/dev-cpp/benchmark/Manifest
+++ b/dev-cpp/benchmark/Manifest
@@ -1,3 +1 @@
-DIST benchmark-1.7.1.tar.gz 196575 BLAKE2B 05a0ae69c0eee231b5d3c06d474c89680e4a2dfaae2ac0ffa1777cf011907cce6230648bfdb631008c2aa10f01b55652f58949849714d6333c5a0351ef42e567 SHA512 396af1c1d3eaa2b78c6d23b1472f6088db85a294056ae1c2366dc5c0becdc8f141ba8fc3a235033324ab0a41c2298f5d242ef09b9b6f69d9877de6bcb2062efd
-DIST benchmark-1.8.0.tar.gz 204701 BLAKE2B d4a2b673152c784efef118b7c5e2971a7f7749b2bbb3b5eb09d1567261853a3e85983e82bbb3a470be72204581a2d031b194cb92d4386e120ffaab71c8a58f6b SHA512 ae8df163ca1319752a03497a259800dc33c71164e7def2feeadcf18d018c64eaf846ea2a562183e3d3cde0af58291de0b091ec6d9c025076f469c403b2ab0d51
DIST benchmark-1.8.2.tar.gz 205926 BLAKE2B b39ee0c983e1b7417c54878507e692d9bc04d83da91c8059ae08373fc59286f28b8910d1d5ea425b0c512502de0aee51b10b1b191bac3ec29ec5f9ffc9056d64 SHA512 532f2cee66cf527ef4452a060cfdedba6417e5d8f72225d6bf50adf6422d9a769b0f54f48982b438fa9ced975ac47bcc5e62c3c23ce871b5cfdbcf9cc0d2b829
diff --git a/dev-cpp/benchmark/benchmark-1.7.1.ebuild b/dev-cpp/benchmark/benchmark-1.7.1.ebuild
deleted file mode 100644
index c0045a92a8c9..000000000000
--- a/dev-cpp/benchmark/benchmark-1.7.1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake flag-o-matic
-
-DESCRIPTION="A microbenchmark support library"
-HOMEPAGE="https://github.com/google/benchmark"
-SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~hppa ~loong ppc ppc64 ~riscv x86"
-IUSE="debug doc lto test"
-
-RESTRICT="!test? ( test )"
-
-BDEPEND="doc? ( app-doc/doxygen )
- test? ( >=dev-cpp/gtest-1.11.0 )"
-
-src_configure() {
- local mycmakeargs=(
- -DBENCHMARK_ENABLE_ASSEMBLY_TESTS=OFF
- -DBENCHMARK_ENABLE_DOXYGEN=$(usex doc)
- -DBENCHMARK_ENABLE_GTEST_TESTS=$(usex test)
- -DBENCHMARK_ENABLE_LTO=$(usex lto)
- -DBENCHMARK_ENABLE_TESTING=$(usex test)
- -DBENCHMARK_ENABLE_WERROR=OFF
- -DBENCHMARK_USE_BUNDLED_GTEST=OFF
- )
-
- use debug || append-cppflags -DNDEBUG
-
- cmake_src_configure
-}
diff --git a/dev-cpp/benchmark/benchmark-1.8.0.ebuild b/dev-cpp/benchmark/benchmark-1.8.0.ebuild
deleted file mode 100644
index c0045a92a8c9..000000000000
--- a/dev-cpp/benchmark/benchmark-1.8.0.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake flag-o-matic
-
-DESCRIPTION="A microbenchmark support library"
-HOMEPAGE="https://github.com/google/benchmark"
-SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~hppa ~loong ppc ppc64 ~riscv x86"
-IUSE="debug doc lto test"
-
-RESTRICT="!test? ( test )"
-
-BDEPEND="doc? ( app-doc/doxygen )
- test? ( >=dev-cpp/gtest-1.11.0 )"
-
-src_configure() {
- local mycmakeargs=(
- -DBENCHMARK_ENABLE_ASSEMBLY_TESTS=OFF
- -DBENCHMARK_ENABLE_DOXYGEN=$(usex doc)
- -DBENCHMARK_ENABLE_GTEST_TESTS=$(usex test)
- -DBENCHMARK_ENABLE_LTO=$(usex lto)
- -DBENCHMARK_ENABLE_TESTING=$(usex test)
- -DBENCHMARK_ENABLE_WERROR=OFF
- -DBENCHMARK_USE_BUNDLED_GTEST=OFF
- )
-
- use debug || append-cppflags -DNDEBUG
-
- cmake_src_configure
-}