summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-16 04:59:17 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-16 05:06:21 +0100
commit5a896111c1d00684b31b8a21669385805c4f367f (patch)
treea696c536f6e61db589696ff9b422aa6f568f94ed
parentdev-python/fonttools: Bump to 4.44.3 (diff)
downloadgentoo-5a896111c1d00684b31b8a21669385805c4f367f.tar.gz
gentoo-5a896111c1d00684b31b8a21669385805c4f367f.tar.bz2
gentoo-5a896111c1d00684b31b8a21669385805c4f367f.zip
dev-python/rich: Bump to 13.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/rich/Manifest1
-rw-r--r--dev-python/rich/rich-13.7.0.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/rich/Manifest b/dev-python/rich/Manifest
index bc93688baf06..666481a284dc 100644
--- a/dev-python/rich/Manifest
+++ b/dev-python/rich/Manifest
@@ -2,3 +2,4 @@ DIST rich-13.4.2.gh.tar.gz 15063000 BLAKE2B f65079440bc7d89a3ff03be01fa71e076493
DIST rich-13.5.2.gh.tar.gz 15064941 BLAKE2B 64f7e879588c42db9ac4f2173647143722c1de4865479b975ac5362e8073f60b493193abb0f50fb0d85923fdbe4145b2331fff7564ab78e3b43bc3a1be9d461c SHA512 60dfc66836f277763695611f6a3890da21afbb84bd85f38952efdac78680a8e3faca2e8c0aa937d618f876df1f36d3e67986979aa4fa9b6cb7dfb214f348b8aa
DIST rich-13.5.3.gh.tar.gz 15065440 BLAKE2B cba268b36499c0f65980ba7b7ce327c53d598b856a39e6c69989b55d488eb0bbe305b6ebf1ca0370251aa8f9ec7dacc6bdee612587a9ace9c66f19d91fdc20b8 SHA512 acae49b796c8ff310b272bca43ce925fe717ddc6252dec20784a4730e63e9c0f81f459ee40b152c001ad0a512e47dddaadbb8fbb949ced262e2d5429b6396344
DIST rich-13.6.0.gh.tar.gz 15055370 BLAKE2B f9182d45ee5ebd802e0b5a02de7a8c27b98770fc97be7ad098aa0c77076bfe38af8d9434bcf961dd300718e1f4e14ee8bf669a89e8f7a24cd4d9817e11552f81 SHA512 6b954205b3cf5f2b7afd35b2b4f022c973206c8073e6c3f20979e015ebd64359576962d5bd3b29e5feb1dfed54f72def6c7c5d51d7940ed280022cf273b515ec
+DIST rich-13.7.0.gh.tar.gz 15057791 BLAKE2B d474b5817c0e64143313a1d0b66ef0953990196ecef6b0fd62d82828902008fa7293290c7f43c605a0c897ecebecb84e816583da8921cd31fc56c902ead2f5c9 SHA512 c5c432bd73b0c28d9585bce2e122d6b9da0a0744ea7824b4682948f11e153dfc615f5ed94d9531ced422298d352371fba5f25ddf16ca7a1d669f799ab361d984
diff --git a/dev-python/rich/rich-13.7.0.ebuild b/dev-python/rich/rich-13.7.0.ebuild
new file mode 100644
index 000000000000..856c2c6051b5
--- /dev/null
+++ b/dev-python/rich/rich-13.7.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for rendering rich text, tables, etc. to the terminal"
+HOMEPAGE="
+ https://github.com/Textualize/rich/
+ https://pypi.org/project/rich/
+"
+SRC_URI="
+ https://github.com/Textualize/rich/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/colorama[${PYTHON_USEDEP}]
+ >=dev-python/markdown-it-py-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.13.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/test_console.py::test_size_can_fall_back_to_std_descriptors
+ # TODO: segfault in recursion (PyQt6 interfering?)
+ tests/test_traceback.py::test_recursive
+ )
+ # version-specific output -- the usual deal
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # pypy3.10, to be more precise
+ tests/test_inspect.py::test_inspect_integer_with_methods_python310only
+ )
+ ;;
+ esac
+
+ local -x COLUMNS=80
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+pkg_postinst() {
+ optfeature "integration with HTML widgets for Jupyter" dev-python/ipywidgets
+}