summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-02-12 23:17:39 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-02-12 23:18:12 +0100
commit5c2eb86b358dbc9047cbac088d7cfe805be04301 (patch)
treee1bbdd2d4e61ab4fc2fa96fb08a5b7e1bed04331
parentdev-python/networkx: Stabilize 3.0 ALLARCHES, #894100 (diff)
downloadgentoo-5c2eb86b358dbc9047cbac088d7cfe805be04301.tar.gz
gentoo-5c2eb86b358dbc9047cbac088d7cfe805be04301.tar.bz2
gentoo-5c2eb86b358dbc9047cbac088d7cfe805be04301.zip
app-arch/dtrx: new package; add 8.5.0 and live
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-arch/dtrx/Manifest1
-rw-r--r--app-arch/dtrx/dtrx-8.5.0.ebuild51
-rw-r--r--app-arch/dtrx/dtrx-9999.ebuild51
-rw-r--r--app-arch/dtrx/metadata.xml14
4 files changed, 117 insertions, 0 deletions
diff --git a/app-arch/dtrx/Manifest b/app-arch/dtrx/Manifest
new file mode 100644
index 000000000000..304aa96c2903
--- /dev/null
+++ b/app-arch/dtrx/Manifest
@@ -0,0 +1 @@
+DIST dtrx-8.5.0.tar.gz 34061 BLAKE2B d8ecbd9f3594440656e40d811846dd302d271f189711176a406572871db69f98bb4fd81a76ebdce697faf8d56029f4dcf735d18795adf732809e6017a7395cf2 SHA512 0ef0c0c9c22d948f6a8ee801372605dae52f4f571a32bbaa180c2c1daab061d623119c91b745f6a86cd28d7d08cdb47029a4de38354bdb28c62acfab080cc0f1
diff --git a/app-arch/dtrx/dtrx-8.5.0.ebuild b/app-arch/dtrx/dtrx-8.5.0.ebuild
new file mode 100644
index 000000000000..03c4b8340d0c
--- /dev/null
+++ b/app-arch/dtrx/dtrx-8.5.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Do The Right eXtraction - extracts archives of different formats"
+HOMEPAGE="https://github.com/dtrx-py/dtrx/
+ https://pypi.org/project/dtrx/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}-py/${PN}.git"
+else
+ SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( README.md )
+
+pkg_postinst() {
+ local supported_format
+ local -a supported_formats=(
+ arj
+ bzip2
+ cpio
+ gzip
+ lrzip
+ lzip
+ p7zip
+ rpm
+ unrar
+ unzip
+ xz-utils
+ zip
+ zstd
+ )
+
+ for supported_format in ${supported_formats[@]}; do
+ optfeature \
+ "extraction of supported archives using ${supported_format}" \
+ app-arch/${supported_format}
+ done
+}
diff --git a/app-arch/dtrx/dtrx-9999.ebuild b/app-arch/dtrx/dtrx-9999.ebuild
new file mode 100644
index 000000000000..03c4b8340d0c
--- /dev/null
+++ b/app-arch/dtrx/dtrx-9999.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Do The Right eXtraction - extracts archives of different formats"
+HOMEPAGE="https://github.com/dtrx-py/dtrx/
+ https://pypi.org/project/dtrx/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}-py/${PN}.git"
+else
+ SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( README.md )
+
+pkg_postinst() {
+ local supported_format
+ local -a supported_formats=(
+ arj
+ bzip2
+ cpio
+ gzip
+ lrzip
+ lzip
+ p7zip
+ rpm
+ unrar
+ unzip
+ xz-utils
+ zip
+ zstd
+ )
+
+ for supported_format in ${supported_formats[@]}; do
+ optfeature \
+ "extraction of supported archives using ${supported_format}" \
+ app-arch/${supported_format}
+ done
+}
diff --git a/app-arch/dtrx/metadata.xml b/app-arch/dtrx/metadata.xml
new file mode 100644
index 000000000000..ed325e58479b
--- /dev/null
+++ b/app-arch/dtrx/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/dtrx-py/dtrx/issues/</bugs-to>
+ <remote-id type="github">dtrx-py/dtrx</remote-id>
+ <remote-id type="pypi">dtrx</remote-id>
+ </upstream>
+</pkgmetadata>