summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-02 10:17:21 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-02 10:29:28 +0100
commit5d304437ae50e19b4d7b8a3d9f33262c26374fe3 (patch)
treedeb47f8812695ac627f781bf72eb8cceb5e92474
parentapp-emacs/markdown-mode: Version bump to 2.4 (diff)
downloadgentoo-5d304437.tar.gz
gentoo-5d304437.tar.bz2
gentoo-5d304437.zip
dev-python/reportlab: Bump to 3.5.58
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/reportlab/Manifest1
-rw-r--r--dev-python/reportlab/reportlab-3.5.58.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/reportlab/Manifest b/dev-python/reportlab/Manifest
index 2bbebb5f0b23..68ffdf6c4b78 100644
--- a/dev-python/reportlab/Manifest
+++ b/dev-python/reportlab/Manifest
@@ -2,3 +2,4 @@ DIST pfbfer-20070710.zip 677333 BLAKE2B 100214476a361a5e5d1f3da0999591345f6e3a3f
DIST reportlab-3.5.48.tar.gz 2890211 BLAKE2B bf0cde9b9e80459caee37949dc90a777a56da5d2c8e6dde09bddbdac2f2c55031d92b3c7c6346b6f563904525020c0e4f666b5e2effdd761c81412df21ec60eb SHA512 ce31cb7e9e2226cb6d59d446f90c1df94f0f84077d298f7ba862f5c75995afa20fa077b1ee1ab9a145c9276cee0d75fe61237e001ad0e5b96dfb0027adff3db7
DIST reportlab-3.5.56.tar.gz 2899527 BLAKE2B 83f14c472a8675449e2f50f806fc5136fceb2c2f307ebd2d34ecad98ce6a67f62971869e05b7d4fe7017b5e728d21d16037ef6f04c3639b0cec8069851e46b64 SHA512 49bafe1b1f0067df1d76a8e61b35ec7062dfffa608f6086241dfa589244bef5784180de7c3d86dc62334282a40a012f7579f5c3cec3c4b0387ba2c482a04c010
DIST reportlab-3.5.57.tar.gz 2901465 BLAKE2B ecb0459414d359b8feb048ad34cfd782a6913f2e254f6d8832dd076fe63fda82d24c4dda28da9c0cc6765c284d51a45d44459d225899574625212c33800116dc SHA512 d325e389ddd7d3c4d98e462956a3c4b7237c9219728577a1e0599a137d19a27205b223fd13c5c260e2968c435bc06b2e4745945ac056926543a47e52868e21db
+DIST reportlab-3.5.58.tar.gz 2903638 BLAKE2B ac19bda75e111266b35a939fc64ac44de4ad69dc7a7cbf9fdabc233e28f33589ba97dc5082cd38d5b8d11a2c7aaab0bac69a1453d8661fd26017f8e07299c2e8 SHA512 949b50f65ca305f79fbb06e7e7b1ebfb6546864892f764a3440eaed0a95ac001a71d3685e8702032573ed60893b9529bd2356b1d5419882058a3b9aab986cb64
diff --git a/dev-python/reportlab/reportlab-3.5.58.ebuild b/dev-python/reportlab/reportlab-3.5.58.ebuild
new file mode 100644
index 000000000000..8a6c3623a1a3
--- /dev/null
+++ b/dev-python/reportlab/reportlab-3.5.58.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Tools for generating printable PDF documents from any data source"
+HOMEPAGE="
+ https://www.reportlab.com/
+ https://pypi.org/project/reportlab/"
+SRC_URI="
+ mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz
+ https://www.reportlab.com/ftp/fonts/pfbfer-20070710.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ media-libs/freetype
+ media-libs/libart_lgpl
+ sys-libs/zlib:="
+RDEPEND="
+ ${DEPEND}
+ dev-python/pillow[tiff,truetype,jpeg(+),${PYTHON_USEDEP}]"
+BDEPEND="
+ app-arch/unzip
+ test? ( ${RDEPEND} )"
+
+distutils_enable_sphinx docs/source
+
+PATCHES=(
+ # bug 738312, remove -L/usr/lib from link line
+ "${FILESDIR}"/${PN}-3.5.48-usr-lib-LLD.patch
+)
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${P}/src/reportlab/fonts || die
+ unpack pfbfer-20070710.zip
+}
+
+python_prepare_all() {
+ # tests requiring Internet access
+ sed -i -e 's:test0:_&:' \
+ tests/test_platypus_general.py \
+ tests/test_platypus_images.py || die
+ sed -i -e 's:test9:_&:' tests/test_lib_utils.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ pushd tests >/dev/null || die
+ "${EPYTHON}" runAll.py || die "Testing failed with ${EPYTHON}"
+ popd >/dev/null || die
+}