summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-05-14 20:44:03 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-05-14 20:44:03 +0300
commit5e8f8a858d135186408b5b797f7a4b0d4d5f1ec8 (patch)
tree9d3ca32d6d9ba59d454afdc0585b3ad051d00f35
parentdev-python/pytest-env: enable py3.11 (diff)
downloadgentoo-5e8f8a858d135186408b5b797f7a4b0d4d5f1ec8.tar.gz
gentoo-5e8f8a858d135186408b5b797f7a4b0d4d5f1ec8.tar.bz2
gentoo-5e8f8a858d135186408b5b797f7a4b0d4d5f1ec8.zip
dev-python/pytest-faulthandler: EAPI=8, PEP517
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/pytest-faulthandler/pytest-faulthandler-2.0.1-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/pytest-faulthandler/pytest-faulthandler-2.0.1-r1.ebuild b/dev-python/pytest-faulthandler/pytest-faulthandler-2.0.1-r1.ebuild
new file mode 100644
index 000000000000..9ca73b3ca2ae
--- /dev/null
+++ b/dev-python/pytest-faulthandler/pytest-faulthandler-2.0.1-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Pytest plugin that activates the fault handler module for tests"
+HOMEPAGE="https://github.com/pytest-dev/pytest-faulthandler"
+SRC_URI="
+ https://github.com/pytest-dev/pytest-faulthandler/archive/${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-5.0[${PYTHON_USEDEP}]
+"