summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pytest-faulthandler/pytest-faulthandler-2.0.1-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/pytest-faulthandler/pytest-faulthandler-2.0.1-r1.ebuild b/dev-python/pytest-faulthandler/pytest-faulthandler-2.0.1-r1.ebuild
new file mode 100644
index 000000000000..9ca73b3ca2ae
--- /dev/null
+++ b/dev-python/pytest-faulthandler/pytest-faulthandler-2.0.1-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Pytest plugin that activates the fault handler module for tests"
+HOMEPAGE="https://github.com/pytest-dev/pytest-faulthandler"
+SRC_URI="
+ https://github.com/pytest-dev/pytest-faulthandler/archive/${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-5.0[${PYTHON_USEDEP}]
+"