summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-16 15:54:11 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-16 15:56:10 +0200
commit5fb3a2922ec536935f6e6013d963e83e03b8bf2a (patch)
tree3e1d21c1fe56f7ab78be1543eb3e59ece38696f3
parentdev-python/jupyter-server: Bump to 2.8.0 (diff)
downloadgentoo-5fb3a2922ec536935f6e6013d963e83e03b8bf2a.tar.gz
gentoo-5fb3a2922ec536935f6e6013d963e83e03b8bf2a.tar.bz2
gentoo-5fb3a2922ec536935f6e6013d963e83e03b8bf2a.zip
dev-python/autopage: Bump to 0.5.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/autopage/Manifest1
-rw-r--r--dev-python/autopage/autopage-0.5.2.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/autopage/Manifest b/dev-python/autopage/Manifest
index e6fa6e3fb264..746b49f9bf13 100644
--- a/dev-python/autopage/Manifest
+++ b/dev-python/autopage/Manifest
@@ -1 +1,2 @@
DIST autopage-0.5.1.gh.tar.gz 21406 BLAKE2B 45d67443fa882d6f824ea71a8f9d20eb1ae789a271d84dc566a2535de631b5ce644aa28f51c5be1db818194e39628b6526ac087cd6eccc425132f15fafda10e9 SHA512 3d6e10c222566fd5f5e07e3247ebe19ce7ffe3b4baf9948741ee9a8aaafbefb0fcfaf4b26f0a4a6392615e73c7e8539c9bcbff1112a291c193c0b653f33e8657
+DIST autopage-0.5.2.gh.tar.gz 21904 BLAKE2B 73597326f6d22d4cac9c9969edc0e6fc23f555d149947aa3aa81529347928a3f9112e9fb15a3ad65e17274ed308fb6fe20810d8364415fe7e59ab1bd47411361 SHA512 68e76dd4c4f049785e226eae499be85139bf57c59fd2161f5bb9df66878541e39a3edc1806f42382bd2d9a922cbdace0d05b60366f72d9a39c31fc39eae05883
diff --git a/dev-python/autopage/autopage-0.5.2.ebuild b/dev-python/autopage/autopage-0.5.2.ebuild
new file mode 100644
index 000000000000..332528ed561f
--- /dev/null
+++ b/dev-python/autopage/autopage-0.5.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library to provide automatic paging for console output"
+HOMEPAGE="
+ https://github.com/zaneb/autopage/
+ https://pypi.org/project/autopage/
+"
+SRC_URI="
+ https://github.com/zaneb/autopage/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ sed -e 's/test_short_streaming_output/_&/' \
+ -e 's/test_interrupt_early/_&/' \
+ -i autopage/tests/test_end_to_end.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ unset LESS PAGER
+ eunittest
+}