summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-08-21 19:51:25 +0100
committerSam James <sam@gentoo.org>2023-08-21 19:51:28 +0100
commit601e8e4384e245502f3141bf3770df030508fc69 (patch)
treecda3f956d3d6d33342c3843303b5826b45d0ad18
parentdev-util/bloaty: protobuf now needs >=c++14 (diff)
downloadgentoo-601e8e4384e245502f3141bf3770df030508fc69.tar.gz
gentoo-601e8e4384e245502f3141bf3770df030508fc69.tar.bz2
gentoo-601e8e4384e245502f3141bf3770df030508fc69.zip
net-misc/mosh: protobuf now needs >=c++14
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-misc/mosh/mosh-1.3.2-r3.ebuild7
-rw-r--r--net-misc/mosh/mosh-1.4.0.ebuild5
2 files changed, 9 insertions, 3 deletions
diff --git a/net-misc/mosh/mosh-1.3.2-r3.ebuild b/net-misc/mosh/mosh-1.3.2-r3.ebuild
index bb82ed9190a5..3e73eb1a4743 100644
--- a/net-misc/mosh/mosh-1.3.2-r3.ebuild
+++ b/net-misc/mosh/mosh-1.3.2-r3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit autotools bash-completion-r1
+inherit autotools bash-completion-r1 flag-o-matic
DESCRIPTION="Mobile shell that supports roaming and intelligent local echo"
HOMEPAGE="https://mosh.org"
@@ -49,6 +49,9 @@ src_prepare() {
}
src_configure() {
+ # protobuf needs >=c++14
+ append-flags -std=gnu++14
+
econf \
--disable-completion \
$(use_enable client) \
diff --git a/net-misc/mosh/mosh-1.4.0.ebuild b/net-misc/mosh/mosh-1.4.0.ebuild
index 7f9a5b4d44c5..0508d2dd4db1 100644
--- a/net-misc/mosh/mosh-1.4.0.ebuild
+++ b/net-misc/mosh/mosh-1.4.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit autotools bash-completion-r1
+inherit autotools bash-completion-r1 flag-o-matic
MY_P=${PN}-${PV/_rc/rc}
DESCRIPTION="Mobile shell that supports roaming and intelligent local echo"
@@ -57,6 +57,9 @@ src_prepare() {
src_configure() {
MAKEOPTS+=" V=1"
+ # protobuf needs >=c++14
+ append-flags -std=gnu++14
+
local myeconfargs=(
# We install it ourselves in src_install
--disable-completion