summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-11-29 20:11:07 +0100
committerLars Wendler <polynomial-c@gentoo.org>2020-11-29 20:11:35 +0100
commit61a87161d544d2ea59fc2a253e475c1dea83e6ad (patch)
treed3e489a067a252bdf9757518d97e78a978e0059e
parentapp-shells/bash: Backport system-readline sed fixes (diff)
downloadgentoo-61a87161.tar.gz
gentoo-61a87161.tar.bz2
gentoo-61a87161.zip
app-shells/bash: Replaced emktemp call with ${T}
Package-Manager: Portage-3.0.11, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--app-shells/bash/bash-5.0_p18.ebuild2
-rw-r--r--app-shells/bash/bash-5.1_rc3.ebuild2
2 files changed, 2 insertions, 2 deletions
diff --git a/app-shells/bash/bash-5.0_p18.ebuild b/app-shells/bash/bash-5.0_p18.ebuild
index 1b63b4bac05b..034c887986cc 100644
--- a/app-shells/bash/bash-5.0_p18.ebuild
+++ b/app-shells/bash/bash-5.0_p18.ebuild
@@ -247,7 +247,7 @@ pkg_preinst() {
# rewrite the symlink to ensure that its mtime changes. having /bin/sh
# missing even temporarily causes a fatal error with paludis.
local target=$(readlink "${EROOT}"/bin/sh)
- local tmp=$(emktemp "${EROOT}"/bin)
+ local tmp="${T}"/sh
ln -sf "${target}" "${tmp}"
mv -f "${tmp}" "${EROOT}"/bin/sh
fi
diff --git a/app-shells/bash/bash-5.1_rc3.ebuild b/app-shells/bash/bash-5.1_rc3.ebuild
index 0c6c61907b2c..e8efbe608c08 100644
--- a/app-shells/bash/bash-5.1_rc3.ebuild
+++ b/app-shells/bash/bash-5.1_rc3.ebuild
@@ -247,7 +247,7 @@ pkg_preinst() {
# rewrite the symlink to ensure that its mtime changes. having /bin/sh
# missing even temporarily causes a fatal error with paludis.
local target=$(readlink "${EROOT}"/bin/sh)
- local tmp=$(emktemp "${EROOT}"/bin)
+ local tmp="${T}"/sh
ln -sf "${target}" "${tmp}"
mv -f "${tmp}" "${EROOT}"/bin/sh
fi