summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2020-12-13 20:50:51 +0100
committerDennis Lamm <expeditioneer@gentoo.org>2020-12-13 21:23:45 +0100
commit629bc57e66c8eee5e59170485e200f108af203ed (patch)
tree544031dd79eaff8a61c72b4f7791081e2cf74cff
parentxfce-base/libxfce4util: Bump to 4.15.6 (diff)
downloadgentoo-629bc57e66c8eee5e59170485e200f108af203ed.tar.gz
gentoo-629bc57e66c8eee5e59170485e200f108af203ed.tar.bz2
gentoo-629bc57e66c8eee5e59170485e200f108af203ed.zip
dev-libs/miniz: new ebuild
Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/18642 Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org>
-rw-r--r--dev-libs/miniz/Manifest1
-rw-r--r--dev-libs/miniz/metadata.xml20
-rw-r--r--dev-libs/miniz/miniz-2.1.0.ebuild29
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-libs/miniz/Manifest b/dev-libs/miniz/Manifest
new file mode 100644
index 000000000000..c7204638ad30
--- /dev/null
+++ b/dev-libs/miniz/Manifest
@@ -0,0 +1 @@
+DIST miniz-2.1.0.tar.gz 104502 BLAKE2B 9a7b3818b454809cdfec523d98f13bef3a52e27b6d3857d289438978d12997e38c71aa97fffe060a6b765f8fbbdd8fe8cebced4a45d9f1f040dd3e39cf2a8055 SHA512 e0aba16afdf230d1e54d0a9cedd336b0b158b02744839f0547e14ee47a97fc1a6668f3a181bd46e969b01b158af18dc8ed3c0a4210b3b620242338a2788806b3
diff --git a/dev-libs/miniz/metadata.xml b/dev-libs/miniz/metadata.xml
new file mode 100644
index 000000000000..8cf9d7cdd9de
--- /dev/null
+++ b/dev-libs/miniz/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>3dprint@gentoo.org</email>
+ <name>Gentoo 3D Printer Project</name>
+ </maintainer>
+ <longdescription>
+ Miniz is a lossless, high performance data compression library in a single source file that implements the zlib
+ (RFC 1950) and Deflate (RFC 1951) compressed data format specification standards. It supports the most commonly
+ used functions exported by the zlib library, but is a completely independent implementation so zlib's licensing
+ requirements do not apply. Miniz also contains simple to use functions for writing .PNG format image files and
+ reading/writing/appending .ZIP format archives. Miniz's compression speed has been tuned to be comparable to
+ zlib's, and it also has a specialized real-time compressor function designed to compare well against
+ fastlz/minilzo.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">richgel999/miniz</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-libs/miniz/miniz-2.1.0.ebuild b/dev-libs/miniz/miniz-2.1.0.ebuild
new file mode 100644
index 000000000000..1141b3f020ce
--- /dev/null
+++ b/dev-libs/miniz/miniz-2.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="A mesh slicer to generate G-code for fused-filament-fabrication (3D printers)"
+HOMEPAGE="https://github.com/richgel999/miniz"
+SRC_URI="https://github.com/richgel999/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DOCS=( ChangeLog.md LICENSE readme.md )
+
+src_prepare() {
+ sed -i -e 's/DESTINATION lib/DESTINATION ${CMAKE_INSTALL_LIBDIR}/' CMakeLists.txt
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ CMAKE_BUILD_TYPE=Release
+
+ cmake_src_configure
+}