summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-05-10 18:03:24 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2024-05-13 17:38:01 +0300
commit6550c189262b5296cdf71aacb6f2b431b6b33473 (patch)
tree4cff7fb6a0320ab00b63e52133529d5ef297896a
parentapp-arch/mt-st: EAPI8 bump (diff)
downloadgentoo-6550c189262b5296cdf71aacb6f2b431b6b33473.tar.gz
gentoo-6550c189262b5296cdf71aacb6f2b431b6b33473.tar.bz2
gentoo-6550c189262b5296cdf71aacb6f2b431b6b33473.zip
app-arch/mt-st: add 1.7
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/36629 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--app-arch/mt-st/Manifest1
-rw-r--r--app-arch/mt-st/mt-st-1.7.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/app-arch/mt-st/Manifest b/app-arch/mt-st/Manifest
index 248625d6d3de..951b0060014d 100644
--- a/app-arch/mt-st/Manifest
+++ b/app-arch/mt-st/Manifest
@@ -1 +1,2 @@
DIST mt-st-1.4.tar.gz 37864 BLAKE2B 25ae656b6442e53570366405ba76da9150cf1d4fe33c612bf922d8be967ce6b60be191948507a62bb1881d4be63ed192f7d03f1d63c38f5772aec2f3d2fe455b SHA512 e6655a5957d3ac470c0cb0a1955a12397aa22f3ea1a427cf776f6bf2d6fd665439b2bfa54c3870b7974da537f0fe71d3be43126be1a7db903e6bc7be4cfb10ec
+DIST mt-st-1.7.tar.gz 39932 BLAKE2B 4083160035972cef89ba18a990c274730241819904cd08f88cbca7fd777a43d9d5fc551fb6de2b5b935818bf32d67eb00dd0002e3a67a82b28a79c17d2c7d369 SHA512 a274d098d8d028d0b32f38104645b628fad549708cc8ff87eb4155ed6270549bdf162a9ccdad468696f35ebe3f86b8923490bb969e7c22b4f827d65b87c5c3cb
diff --git a/app-arch/mt-st/mt-st-1.7.ebuild b/app-arch/mt-st/mt-st-1.7.ebuild
new file mode 100644
index 000000000000..82ebcff528b1
--- /dev/null
+++ b/app-arch/mt-st/mt-st-1.7.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Control magnetic tape drive operation"
+HOMEPAGE="https://github.com/iustin/mt-st"
+SRC_URI="https://github.com/iustin/mt-st/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ dosbin mt stinit
+ doman mt.1 stinit.8
+ dodoc README* stinit.def.examples
+}