summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-01-30 13:55:01 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-02-02 07:16:10 +0100
commit65532a5bfb4da75244076ad7ea202e836dd3eb87 (patch)
treecb95d199c540251f9b635aeb9e10446f2e084263
parentsys-boot/grub: add installkernel as optfeature (diff)
downloadgentoo-65532a5bfb4da75244076ad7ea202e836dd3eb87.tar.gz
gentoo-65532a5bfb4da75244076ad7ea202e836dd3eb87.tar.bz2
gentoo-65532a5bfb4da75244076ad7ea202e836dd3eb87.zip
sys-apps/systemd: add installkernel as optfeature
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--sys-apps/systemd/systemd-254.5-r2.ebuild11
-rw-r--r--sys-apps/systemd/systemd-254.7-r1.ebuild11
-rw-r--r--sys-apps/systemd/systemd-254.8-r1.ebuild11
-rw-r--r--sys-apps/systemd/systemd-254.9.ebuild11
-rw-r--r--sys-apps/systemd/systemd-255.2-r2.ebuild11
-rw-r--r--sys-apps/systemd/systemd-255.3.ebuild11
-rw-r--r--sys-apps/systemd/systemd-9999.ebuild11
7 files changed, 70 insertions, 7 deletions
diff --git a/sys-apps/systemd/systemd-254.5-r2.ebuild b/sys-apps/systemd/systemd-254.5-r2.ebuild
index 5c099abdbcd5..94a29b1079b9 100644
--- a/sys-apps/systemd/systemd-254.5-r2.ebuild
+++ b/sys-apps/systemd/systemd-254.5-r2.ebuild
@@ -26,7 +26,7 @@ else
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
fi
-inherit bash-completion-r1 linux-info meson-multilib pam python-single-r1
+inherit bash-completion-r1 linux-info meson-multilib optfeature pam python-single-r1
inherit secureboot systemd toolchain-funcs udev usr-ldscript
DESCRIPTION="System and service manager for Linux"
@@ -520,6 +520,15 @@ pkg_postinst() {
eerror "systemd again."
eerror
fi
+
+ if use boot; then
+ optfeature "automatically installing the kernels in systemd-boot's native layout and updating the bootloader configuration" \
+ "sys-kernel/installkernel[systemd-boot]"
+ fi
+ if use ukify; then
+ optfeature "automatically generating an unified kernel image on each kernel installation" \
+ "sys-kernel/installkernel[ukify]"
+ fi
}
pkg_prerm() {
diff --git a/sys-apps/systemd/systemd-254.7-r1.ebuild b/sys-apps/systemd/systemd-254.7-r1.ebuild
index 89798cf92eff..a3b0cb5166c9 100644
--- a/sys-apps/systemd/systemd-254.7-r1.ebuild
+++ b/sys-apps/systemd/systemd-254.7-r1.ebuild
@@ -26,7 +26,7 @@ else
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
fi
-inherit bash-completion-r1 linux-info meson-multilib pam python-single-r1
+inherit bash-completion-r1 linux-info meson-multilib optfeature pam python-single-r1
inherit secureboot systemd toolchain-funcs udev usr-ldscript
DESCRIPTION="System and service manager for Linux"
@@ -520,6 +520,15 @@ pkg_postinst() {
eerror "systemd again."
eerror
fi
+
+ if use boot; then
+ optfeature "automatically installing the kernels in systemd-boot's native layout and updating the bootloader configuration" \
+ "sys-kernel/installkernel[systemd-boot]"
+ fi
+ if use ukify; then
+ optfeature "automatically generating an unified kernel image on each kernel installation" \
+ "sys-kernel/installkernel[ukify]"
+ fi
}
pkg_prerm() {
diff --git a/sys-apps/systemd/systemd-254.8-r1.ebuild b/sys-apps/systemd/systemd-254.8-r1.ebuild
index 66413a320d66..99f6639000b5 100644
--- a/sys-apps/systemd/systemd-254.8-r1.ebuild
+++ b/sys-apps/systemd/systemd-254.8-r1.ebuild
@@ -26,7 +26,7 @@ else
KEYWORDS="~alpha ~amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ppc64 ~riscv ~s390 ~sparc ~x86"
fi
-inherit bash-completion-r1 linux-info meson-multilib pam python-single-r1
+inherit bash-completion-r1 linux-info meson-multilib optfeature pam python-single-r1
inherit secureboot systemd toolchain-funcs udev usr-ldscript
DESCRIPTION="System and service manager for Linux"
@@ -521,6 +521,15 @@ pkg_postinst() {
eerror "systemd again."
eerror
fi
+
+ if use boot; then
+ optfeature "automatically installing the kernels in systemd-boot's native layout and updating the bootloader configuration" \
+ "sys-kernel/installkernel[systemd-boot]"
+ fi
+ if use ukify; then
+ optfeature "automatically generating an unified kernel image on each kernel installation" \
+ "sys-kernel/installkernel[ukify]"
+ fi
}
pkg_prerm() {
diff --git a/sys-apps/systemd/systemd-254.9.ebuild b/sys-apps/systemd/systemd-254.9.ebuild
index e56d6a526190..c12a9240f822 100644
--- a/sys-apps/systemd/systemd-254.9.ebuild
+++ b/sys-apps/systemd/systemd-254.9.ebuild
@@ -26,7 +26,7 @@ else
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
fi
-inherit bash-completion-r1 linux-info meson-multilib pam python-single-r1
+inherit bash-completion-r1 linux-info meson-multilib optfeature pam python-single-r1
inherit secureboot systemd toolchain-funcs udev usr-ldscript
DESCRIPTION="System and service manager for Linux"
@@ -521,6 +521,15 @@ pkg_postinst() {
eerror "systemd again."
eerror
fi
+
+ if use boot; then
+ optfeature "automatically installing the kernels in systemd-boot's native layout and updating the bootloader configuration" \
+ "sys-kernel/installkernel[systemd-boot]"
+ fi
+ if use ukify; then
+ optfeature "automatically generating an unified kernel image on each kernel installation" \
+ "sys-kernel/installkernel[ukify]"
+ fi
}
pkg_prerm() {
diff --git a/sys-apps/systemd/systemd-255.2-r2.ebuild b/sys-apps/systemd/systemd-255.2-r2.ebuild
index 058e82af1331..85965aed1d27 100644
--- a/sys-apps/systemd/systemd-255.2-r2.ebuild
+++ b/sys-apps/systemd/systemd-255.2-r2.ebuild
@@ -29,7 +29,7 @@ else
fi
fi
-inherit bash-completion-r1 linux-info meson-multilib pam python-single-r1
+inherit bash-completion-r1 linux-info meson-multilib optfeature pam python-single-r1
inherit secureboot systemd toolchain-funcs udev
DESCRIPTION="System and service manager for Linux"
@@ -505,6 +505,15 @@ pkg_postinst() {
eerror "systemd again."
eerror
fi
+
+ if use boot; then
+ optfeature "automatically installing the kernels in systemd-boot's native layout and updating the bootloader configuration" \
+ "sys-kernel/installkernel[systemd-boot]"
+ fi
+ if use ukify; then
+ optfeature "automatically generating an unified kernel image on each kernel installation" \
+ "sys-kernel/installkernel[ukify]"
+ fi
}
pkg_prerm() {
diff --git a/sys-apps/systemd/systemd-255.3.ebuild b/sys-apps/systemd/systemd-255.3.ebuild
index 8d38529e33fb..288cbd927d82 100644
--- a/sys-apps/systemd/systemd-255.3.ebuild
+++ b/sys-apps/systemd/systemd-255.3.ebuild
@@ -29,7 +29,7 @@ else
fi
fi
-inherit bash-completion-r1 linux-info meson-multilib pam python-single-r1
+inherit bash-completion-r1 linux-info meson-multilib optfeature pam python-single-r1
inherit secureboot systemd toolchain-funcs udev
DESCRIPTION="System and service manager for Linux"
@@ -505,6 +505,15 @@ pkg_postinst() {
eerror "systemd again."
eerror
fi
+
+ if use boot; then
+ optfeature "automatically installing the kernels in systemd-boot's native layout and updating the bootloader configuration" \
+ "sys-kernel/installkernel[systemd-boot]"
+ fi
+ if use ukify; then
+ optfeature "automatically generating an unified kernel image on each kernel installation" \
+ "sys-kernel/installkernel[ukify]"
+ fi
}
pkg_prerm() {
diff --git a/sys-apps/systemd/systemd-9999.ebuild b/sys-apps/systemd/systemd-9999.ebuild
index 058e82af1331..85965aed1d27 100644
--- a/sys-apps/systemd/systemd-9999.ebuild
+++ b/sys-apps/systemd/systemd-9999.ebuild
@@ -29,7 +29,7 @@ else
fi
fi
-inherit bash-completion-r1 linux-info meson-multilib pam python-single-r1
+inherit bash-completion-r1 linux-info meson-multilib optfeature pam python-single-r1
inherit secureboot systemd toolchain-funcs udev
DESCRIPTION="System and service manager for Linux"
@@ -505,6 +505,15 @@ pkg_postinst() {
eerror "systemd again."
eerror
fi
+
+ if use boot; then
+ optfeature "automatically installing the kernels in systemd-boot's native layout and updating the bootloader configuration" \
+ "sys-kernel/installkernel[systemd-boot]"
+ fi
+ if use ukify; then
+ optfeature "automatically generating an unified kernel image on each kernel installation" \
+ "sys-kernel/installkernel[ukify]"
+ fi
}
pkg_prerm() {