summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2024-04-07 12:49:11 -0400
committerYixun Lan <dlan@gentoo.org>2024-04-08 12:52:24 +0000
commit66ddb572a66c1bc9ac61a624dc40b577daf199c7 (patch)
tree0be12d0ccf58cfe33e867e1a057ea421c7a4e04b
parentgui-libs/hyprcursor: add 0.1.6 (diff)
downloadgentoo-66ddb572a66c1bc9ac61a624dc40b577daf199c7.tar.gz
gentoo-66ddb572a66c1bc9ac61a624dc40b577daf199c7.tar.bz2
gentoo-66ddb572a66c1bc9ac61a624dc40b577daf199c7.zip
gui-wm/hyprland: add 0.38.1
Closes: https://github.com/gentoo/gentoo/pull/36154 Signed-off-by: Julien Roy <julien@jroy.ca> Signed-off-by: Yixun Lan <dlan@gentoo.org>
-rw-r--r--gui-wm/hyprland/Manifest1
-rw-r--r--gui-wm/hyprland/hyprland-0.38.1.ebuild139
2 files changed, 140 insertions, 0 deletions
diff --git a/gui-wm/hyprland/Manifest b/gui-wm/hyprland/Manifest
index 795cdad38016..eebad990956f 100644
--- a/gui-wm/hyprland/Manifest
+++ b/gui-wm/hyprland/Manifest
@@ -1,3 +1,4 @@
DIST hyprland-0.34.0.gh.tar.gz 14128415 BLAKE2B 059fc8b849daeb71b08d7114fd8aea1264c0e9967f471df66b27aca46b95fd499d2929730ba66981bb7d6c423479533b280839db7839ca1df007825f72fb9bf8 SHA512 35cce0668a13d7e7fd220d62efd965a069ff0213996bfa47ca0852c6258881bc070020d4831364b325b71d8ce7373d1793a89006a4341088dcbaf01914920f1a
DIST hyprland-0.37.1.gh.tar.gz 54651435 BLAKE2B 92bd78168909510ffb21b46f7d66e139e7b86f7655c7a8126eaf90b6ef6d7d5affaf0bc55ca1647a2f80b6d767afc00e1efe5f2241b2bc88d20357acee611b92 SHA512 f09316e210805b833a27524894222edc7a048b77f9f5d9cc8faa5b4e37040485ad3b9638f60a346da8d4d4aff24bbd6382b7fde64d07528990e9a521b2f46454
DIST hyprland-0.38.0.gh.tar.gz 54658884 BLAKE2B a0a26f59b0c4967cf58258adc719912855853fc54c5ebf55d42d34ca51905021ce4755eaaaf9c07ca1cabd0502d2a9c2e6bf6455bda10f36c2960b2525738416 SHA512 8452a0dab1c71c336201977318bb24442fe3ca08ae349e31b015f011bbb6d98aaf19dcfdcd31349c85ab837d6cda24dab40409469d0721d930e59aa7e2282153
+DIST hyprland-0.38.1.gh.tar.gz 54701702 BLAKE2B 56f16d938099856be9aea0a089154e58a1d2226f42fc2a81a560e3f3883caed6eb76faa674340a3a4a1632df5a8c1a28d084c64c6749c3452c23ca192bef967b SHA512 addd4cea3f83e17907180288021718a66973c247b261e306accb7b32bbbbd2f0b3f4fcf4c22189614f561c361bfb99ea0645f4698e7af9491379d424d1d1142b
diff --git a/gui-wm/hyprland/hyprland-0.38.1.ebuild b/gui-wm/hyprland/hyprland-0.38.1.ebuild
new file mode 100644
index 000000000000..a2006ea15983
--- /dev/null
+++ b/gui-wm/hyprland/hyprland-0.38.1.ebuild
@@ -0,0 +1,139 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson toolchain-funcs
+
+DESCRIPTION="A dynamic tiling Wayland compositor that doesn't sacrifice on its looks"
+HOMEPAGE="https://github.com/hyprwm/Hyprland"
+
+if [[ "${PV}" = *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/hyprwm/${PN^}.git"
+else
+ SRC_URI="https://github.com/hyprwm/${PN^}/releases/download/v${PV}/source-v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ S="${WORKDIR}/${PN}-source"
+
+ KEYWORDS="~amd64 ~riscv"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="X legacy-renderer systemd"
+
+# hyprpm (hyprland plugin manager) requires the dependencies at runtime
+# so that it can clone, compile and install plugins.
+HYPRPM_RDEPEND="
+ app-alternatives/ninja
+ dev-build/cmake
+ dev-build/meson
+ dev-vcs/git
+ virtual/pkgconfig
+"
+# bundled wlroots has the following dependency string according to included headers.
+# wlroots[drm,gles2-renderer,libinput,x11-backend?,X?]
+# enable x11-backend with X and vice versa
+WLROOTS_DEPEND="
+ >=dev-libs/wayland-1.22
+ media-libs/libglvnd
+ media-libs/mesa[egl(+),gles2]
+ >=x11-libs/libdrm-2.4.114
+ x11-libs/libxkbcommon
+ >=x11-libs/pixman-0.42.0
+ media-libs/libdisplay-info
+ sys-apps/hwdata
+ >=dev-libs/libinput-1.14.0:=
+ sys-auth/seatd:=
+ virtual/libudev:=
+ X? (
+ x11-libs/libxcb:=
+ x11-libs/xcb-util-renderutil
+ x11-libs/xcb-util-wm
+ x11-base/xwayland
+ )
+"
+WLROOTS_RDEPEND="
+ ${WLROOTS_DEPEND}
+"
+WLROOTS_BDEPEND="
+ >=dev-libs/wayland-protocols-1.32
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+RDEPEND="
+ ${HYPRPM_RDEPEND}
+ ${WLROOTS_RDEPEND}
+ dev-cpp/tomlplusplus
+ dev-libs/glib:2
+ dev-libs/libinput
+ >=dev-libs/wayland-1.20.0
+ gui-libs/hyprcursor
+ media-libs/libglvnd
+ x11-libs/cairo
+ x11-libs/libdrm
+ x11-libs/libxkbcommon
+ x11-libs/pango
+ x11-libs/pixman
+ X? (
+ x11-libs/libxcb:0=
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ ${WLROOTS_DEPEND}
+ >=dev-libs/hyprland-protocols-0.2
+ >=dev-libs/hyprlang-0.3.2
+ >=dev-libs/wayland-protocols-1.32
+"
+BDEPEND="
+ ${WLROOTS_BDEPEND}
+ || ( >=sys-devel/gcc-13:* >=sys-devel/clang-16:* )
+ app-misc/jq
+ dev-build/cmake
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} == binary ]] && return
+
+ if tc-is-gcc && ver_test $(gcc-version) -lt 13 ; then
+ eerror "Hyprland requires >=sys-devel/gcc-13 to build"
+ eerror "Please upgrade GCC: emerge -v1 sys-devel/gcc"
+ die "GCC version is too old to compile Hyprland!"
+ elif tc-is-clang && ver_test $(clang-version) -lt 16 ; then
+ eerror "Hyprland requires >=sys-devel/clang-16 to build"
+ eerror "Please upgrade Clang: emerge -v1 sys-devel/clang"
+ die "Clang version is too old to compile Hyprland!"
+ fi
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature legacy-renderer legacy_renderer)
+ $(meson_feature systemd)
+ $(meson_feature X xwayland)
+ $(meson_feature X wlroots:xwayland)
+ -Dwlroots:backends=drm,libinput$(usev X ',x11')
+ -Dwlroots:xcb-errors=disabled
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ # First install everything except wlroots to avoid conflicts.
+ meson_src_install --skip-subprojects wlroots
+ # Then install development files (mainly wlroots) for bug #916760.
+ meson_src_install --tags devel
+
+ # Wlroots headers are required by hyprland-plugins and the pkgconfig file expects
+ # them to be in /usr/include/hyprland/wlroots, despite this they aren't installed there.
+ # Ideally you could override includedir per subproject and the install tags would
+ # be granular enough to only install headers. But its not requiring this.
+ mkdir "${ED}"/usr/include/hyprland/wlroots || die
+ mv "${ED}"/usr/include/wlr "${ED}"/usr/include/hyprland/wlroots || die
+ # devel tag includes wlroots .pc and .a files still
+ rm -rf "${ED}"/usr/$(get_libdir)/ || die
+}