summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2023-10-04 21:08:27 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2023-10-04 21:09:24 -0500
commit67617ecff8ff7cf217856deb773e5d1b57b3606a (patch)
tree48001a1d7a2db4198a03fc505138a69694b33ba6
parentapp-crypt/certbot: add 2.7.0 (diff)
downloadgentoo-67617ecf.tar.gz
gentoo-67617ecf.tar.bz2
gentoo-67617ecf.zip
app-crypt/certbot-apache: add 2.7.0
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--app-crypt/certbot-apache/Manifest1
-rw-r--r--app-crypt/certbot-apache/certbot-apache-2.7.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/app-crypt/certbot-apache/Manifest b/app-crypt/certbot-apache/Manifest
index 6bc3eac1503d..41b4e913854e 100644
--- a/app-crypt/certbot-apache/Manifest
+++ b/app-crypt/certbot-apache/Manifest
@@ -1 +1,2 @@
DIST certbot-2.6.0.gh.tar.gz 1336339 BLAKE2B 0c0575ad553ebe0f3ab56da750572bca46b30d034033e43c30c3793c114050ad824a277eab0be5a47326ea099e58e9a421448b53fc1b9173afae9a0ec308ac62 SHA512 d694156886484511f5a38fb5e40f98b2e2dbe4bc5110c95b2084ec03b39cb0eb9bbc623c7bca4a81054e980c8dbac752949042391813298a27be7e70410882e3
+DIST certbot-2.7.0.gh.tar.gz 1336481 BLAKE2B 224f26819ee55b99a26540e7f56a8466c806d08149cce511d28d77ce9f5fb8073ec65e6cfa3e0c168ca84ddcbf85478ff335b84feaadee66db6c5a811be202be SHA512 1e1defcd143f804a36b50e3104d239bf20873545474ceb654269a5879e15cfbb76a18bd569f5e6e12de1036779e72c74d9896707daabc314fc5d67acc1c5180d
diff --git a/app-crypt/certbot-apache/certbot-apache-2.7.0.ebuild b/app-crypt/certbot-apache/certbot-apache-2.7.0.ebuild
new file mode 100644
index 000000000000..4d1707d36f00
--- /dev/null
+++ b/app-crypt/certbot-apache/certbot-apache-2.7.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+PARENT_PN="${PN%-apache}"
+PARENT_P="${PARENT_PN}-${PV}"
+
+if [[ "${PV}" == *9999 ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ EGIT_SUBMODULES=()
+ EGIT_CHECKOUT_DIR="${WORKDIR}/${PARENT_P}"
+else
+ SRC_URI="
+ https://github.com/certbot/certbot/archive/v${PV}.tar.gz
+ -> ${PARENT_P}.gh.tar.gz
+ "
+ # Only for amd64, arm64 and x86 because of dev-python/python-augeas
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DESCRIPTION="Apache plugin for Certbot (Let’s Encrypt client)"
+HOMEPAGE="
+ https://github.com/certbot/certbot
+ https://letsencrypt.org/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+S="${WORKDIR}/${PARENT_P}/${PN}"
+
+BDEPEND="
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+RDEPEND="
+ >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
+ dev-python/python-augeas[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest