summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-02-24 14:28:59 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-02-24 14:29:45 +0100
commit6937ae9b710432434202a8fb9ed932512e2980a1 (patch)
tree29be4a9f082a5f47469e7b08a5f314c01c25840d
parentmedia-tv/plex-media-server: Plex Media Server 1.25.4.5487 is now available to... (diff)
downloadgentoo-6937ae9b710432434202a8fb9ed932512e2980a1.tar.gz
gentoo-6937ae9b710432434202a8fb9ed932512e2980a1.tar.bz2
gentoo-6937ae9b710432434202a8fb9ed932512e2980a1.zip
sci-geosciences/gpscorrelate: respect CC/CXX and fix compile with clang
Closes: https://bugs.gentoo.org/833990 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--sci-geosciences/gpscorrelate/files/gpscorrelate-2.0-respect-users-flags.patch30
-rw-r--r--sci-geosciences/gpscorrelate/gpscorrelate-2.0.ebuild8
2 files changed, 34 insertions, 4 deletions
diff --git a/sci-geosciences/gpscorrelate/files/gpscorrelate-2.0-respect-users-flags.patch b/sci-geosciences/gpscorrelate/files/gpscorrelate-2.0-respect-users-flags.patch
new file mode 100644
index 000000000000..31519848a7a2
--- /dev/null
+++ b/sci-geosciences/gpscorrelate/files/gpscorrelate-2.0-respect-users-flags.patch
@@ -0,0 +1,30 @@
+diff --git a/Makefile b/Makefile
+index 7634553..9bfd025 100644
+--- a/Makefile
++++ b/Makefile
+@@ -2,12 +2,12 @@
+
+ PACKAGE_VERSION = 2.0
+
+-CC = gcc
+-CXX = g++
++CC ?= gcc
++CXX ?= g++
+ EXEEXT =
+-PKG_CONFIG=pkg-config
+-CFLAGS = -Wall -O2
+-LDFLAGS = -Wall -O2 -lm
++PKG_CONFIG?=pkg-config
++CFLAGS ?= -Wall -O2
++LDFLAGS ?= -Wall -O2
+ GTK = 3
+
+ COBJS = main-command.o unixtime.o gpx-read.o correlate.o exif-gps.o latlong.o
+@@ -20,6 +20,7 @@ CFLAGSINC = `$(PKG_CONFIG) --cflags libxml-2.0 exiv2`
+ GTKFLAGS = `$(PKG_CONFIG) --cflags gtk+-$(GTK).0`
+ LIBS = `$(PKG_CONFIG) --libs libxml-2.0 exiv2`
+ LIBSGUI = `$(PKG_CONFIG) --libs gtk+-$(GTK).0`
++LIBS += -lm -lstdc++
+
+ CFLAGSINC += $(GTKFLAGS)
+
diff --git a/sci-geosciences/gpscorrelate/gpscorrelate-2.0.ebuild b/sci-geosciences/gpscorrelate/gpscorrelate-2.0.ebuild
index 0d45dcd66a4c..982684d854bb 100644
--- a/sci-geosciences/gpscorrelate/gpscorrelate-2.0.ebuild
+++ b/sci-geosciences/gpscorrelate/gpscorrelate-2.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit desktop toolchain-funcs
+inherit desktop
DESCRIPTION="Tool for adjusting EXIF tags of your photos with a recorded GPS trace"
HOMEPAGE="https://dfandrich.github.io/gpscorrelate/"
@@ -28,12 +28,12 @@ RDEPEND="${DEPEND}"
PATCHES=(
"${FILESDIR}/${P}-desktop-pass-validation.patch"
+ "${FILESDIR}/${P}-respect-users-flags.patch"
)
src_compile() {
- tc-export CC CXX PKG_CONFIG
- emake gpscorrelate CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS}"
- use gtk && emake gpscorrelate-gui CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS}"
+ emake gpscorrelate
+ use gtk && emake gpscorrelate-gui
}