summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2021-10-21 21:05:14 +0200
committerJakov Smolić <jsmolic@gentoo.org>2021-10-21 21:05:14 +0200
commit69b1d4acd358834a5c7028aab741694980a969d3 (patch)
tree649aae28315de8bd6cba37efa78c6869adde972b
parentnet-analyzer/ftester: Port to EAPI 8 (diff)
downloadgentoo-69b1d4acd358834a5c7028aab741694980a969d3.tar.gz
gentoo-69b1d4acd358834a5c7028aab741694980a969d3.tar.bz2
gentoo-69b1d4acd358834a5c7028aab741694980a969d3.zip
net-analyzer/rtpbreak: Port to EAPI 8
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
-rw-r--r--net-analyzer/rtpbreak/rtpbreak-1.3a-r2.ebuild (renamed from net-analyzer/rtpbreak/rtpbreak-1.3a-r1.ebuild)17
1 files changed, 8 insertions, 9 deletions
diff --git a/net-analyzer/rtpbreak/rtpbreak-1.3a-r1.ebuild b/net-analyzer/rtpbreak/rtpbreak-1.3a-r2.ebuild
index 557c98956942..bdd5d139be1b 100644
--- a/net-analyzer/rtpbreak/rtpbreak-1.3a-r1.ebuild
+++ b/net-analyzer/rtpbreak/rtpbreak-1.3a-r2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=8
-inherit epatch toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="Analyze any RTP session through heuristics over UDP network traffic"
HOMEPAGE="http://xenion.reactive-search.com/?page_id=7"
@@ -17,11 +17,10 @@ DEPEND="net-libs/libnet:1.1
>=net-libs/libpcap-0.7"
RDEPEND="${DEPEND}"
-src_prepare() {
- # Use limits.h PATH_MAX
- epatch "${FILESDIR}"/${P}-limits.patch \
- "${FILESDIR}"/${P}-missing-headers.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-limits.patch
+ "${FILESDIR}"/${P}-missing-headers.patch
+)
src_compile() {
emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
@@ -29,6 +28,6 @@ src_compile() {
src_install() {
dobin src/rtpbreak
- dodoc CHANGELOG THANKS
- dohtml -r doc
+ einstalldocs
+ dodoc -r doc
}