summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-30 17:30:56 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-30 17:35:58 +0100
commit6ee57b9d1bf3c36b532d540105fa294d4cd9a7cd (patch)
tree64f8411bada7901513ab0b88eb0555fb26b515c0
parentdev-python/pypdf: Backport pytest-8 test fixes (diff)
downloadgentoo-6ee57b9d1bf3c36b532d540105fa294d4cd9a7cd.tar.gz
gentoo-6ee57b9d1bf3c36b532d540105fa294d4cd9a7cd.tar.bz2
gentoo-6ee57b9d1bf3c36b532d540105fa294d4cd9a7cd.zip
dev-python/furo: Unpack when PKGBUMPING, to make diffing possible
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/furo/furo-2023.9.10.ebuild10
-rw-r--r--dev-python/furo/furo-2024.1.29.ebuild6
2 files changed, 14 insertions, 2 deletions
diff --git a/dev-python/furo/furo-2023.9.10.ebuild b/dev-python/furo/furo-2023.9.10.ebuild
index 1c42bf8413e1..d306ea1caab9 100644
--- a/dev-python/furo/furo-2023.9.10.ebuild
+++ b/dev-python/furo/furo-2023.9.10.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2021-2023 Gentoo Authors
+# Copyright 2021-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -22,7 +22,7 @@ S=${WORKDIR}
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ppc ppc64 ~riscv ~s390 sparc x86"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
RDEPEND="
dev-python/beautifulsoup4[${PYTHON_USEDEP}]
@@ -30,6 +30,12 @@ RDEPEND="
dev-python/sphinx-basic-ng[${PYTHON_USEDEP}]
"
+src_unpack() {
+ if [[ ${PKGBUMPING} == ${PVR} ]]; then
+ unzip "${DISTDIR}/${A}" || die
+ fi
+}
+
python_compile() {
distutils_wheel_install "${BUILD_DIR}/install" \
"${DISTDIR}/${P}-py3-none-any.whl"
diff --git a/dev-python/furo/furo-2024.1.29.ebuild b/dev-python/furo/furo-2024.1.29.ebuild
index 1cf4206b8d7e..d306ea1caab9 100644
--- a/dev-python/furo/furo-2024.1.29.ebuild
+++ b/dev-python/furo/furo-2024.1.29.ebuild
@@ -30,6 +30,12 @@ RDEPEND="
dev-python/sphinx-basic-ng[${PYTHON_USEDEP}]
"
+src_unpack() {
+ if [[ ${PKGBUMPING} == ${PVR} ]]; then
+ unzip "${DISTDIR}/${A}" || die
+ fi
+}
+
python_compile() {
distutils_wheel_install "${BUILD_DIR}/install" \
"${DISTDIR}/${P}-py3-none-any.whl"