summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-04-14 13:07:49 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-04-14 17:56:09 +0200
commit6f4413755de098c09d5b5426765ce9b02d5c7405 (patch)
treebc87aabd6a4d735592193ca7ae16503944a4024f
parentmedia-libs/libeot: EAPI8 bump, minor ebuild improvements (diff)
downloadgentoo-6f441375.tar.gz
gentoo-6f441375.tar.bz2
gentoo-6f441375.zip
sci-physics/lhapdf: fix egg install and force bash
Closes: https://bugs.gentoo.org/928105 Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de> Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--sci-physics/lhapdf/lhapdf-6.3.0-r2.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/sci-physics/lhapdf/lhapdf-6.3.0-r2.ebuild b/sci-physics/lhapdf/lhapdf-6.3.0-r2.ebuild
index 03dda6b30a7f..01884ec1f0fe 100644
--- a/sci-physics/lhapdf/lhapdf-6.3.0-r2.ebuild
+++ b/sci-physics/lhapdf/lhapdf-6.3.0-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
DOCS_BUILDER="doxygen"
DOCS_DEPEND="
dev-texlive/texlive-bibtexextra
@@ -52,6 +52,7 @@ src_prepare() {
}
src_configure() {
+ CONFIG_SHELL="${EPREFIX}/bin/bash" \
econf \
--disable-static \
--enable-python
@@ -78,6 +79,7 @@ src_install() {
cd "${S}"/wrappers/python || die
distutils-r1_src_install
+ rm -r "${D}/$(python_get_sitedir)"/*.egg-info || die
find "${ED}" -name '*.la' -delete || die
}