summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-11-04 22:26:00 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2021-11-04 22:27:27 +0200
commit6f5a8faf45ecd27979231bb40f64014752321221 (patch)
tree81b174352bb07629e4a185281514c8e2b6b7d1f1
parentwww-client/chromium: force older dev-util/gn (M95) (diff)
downloadgentoo-6f5a8faf45ecd27979231bb40f64014752321221.tar.gz
gentoo-6f5a8faf45ecd27979231bb40f64014752321221.tar.bz2
gentoo-6f5a8faf45ecd27979231bb40f64014752321221.zip
dev-python/pycson: enable tests, ebuild cleanup
Closes: https://bugs.gentoo.org/798210 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/pycson/pycson-0.8-r1.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/dev-python/pycson/pycson-0.8-r1.ebuild b/dev-python/pycson/pycson-0.8-r1.ebuild
index 330c7ca33866..8f32f7f9890d 100644
--- a/dev-python/pycson/pycson-0.8-r1.ebuild
+++ b/dev-python/pycson/pycson-0.8-r1.ebuild
@@ -2,13 +2,18 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+
+PYTHON_COMPAT=( python3_{8..9} )
inherit distutils-r1
+
DESCRIPTION="A python parser for the Coffeescript Object Notation (CSON)"
HOMEPAGE="https://github.com/avakar/pycson/"
SRC_URI="https://github.com/avakar/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-SLOT="0"
+
LICENSE="MIT"
+SLOT="0"
KEYWORDS="amd64 ~ppc ~riscv x86"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
RDEPEND="dev-python/speg"
+
+distutils_enable_tests pytest