summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2020-11-01 02:51:02 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2020-11-01 02:51:42 +0200
commit7261e631cc6d48f60e5d1f787b084f5cf54925ad (patch)
tree181b774749e05593a76ac05fd21b4ed5b9b8bfce
parentmedia-plugins/kodi-inputstream-adaptive: 2.6.4 version bump (diff)
downloadgentoo-7261e631.tar.gz
gentoo-7261e631.tar.bz2
gentoo-7261e631.zip
net-misc/sipsak: Version bump; apply workaround for gcc-10
Bug: https://bugs.gentoo.org/706350 Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
-rw-r--r--net-misc/sipsak/Manifest1
-rw-r--r--net-misc/sipsak/sipsak-0.9.7.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/net-misc/sipsak/Manifest b/net-misc/sipsak/Manifest
index 5adb817f63f0..dea131e97aab 100644
--- a/net-misc/sipsak/Manifest
+++ b/net-misc/sipsak/Manifest
@@ -1 +1,2 @@
DIST sipsak-0.9.6-1.tar.gz 158776 BLAKE2B c8bd37d63d55bc593a57455171ed2dd26c8a4e87746be7075af7c2912b400d49a44f25fad694e296c75ea9aa3e7b10cc81a457c448a3a9429a41d22b84fb794c SHA512 c2d62ddaf2ecc9616941cf002a0494d2f9c43747e6b527f8b1542e9b5ae143fc69b18fc140bd3f255896b0e8eb02f7d198cc1799a4041e2d0c95d90b653591fe
+DIST sipsak-0.9.7.tar.gz 199074 BLAKE2B c99bc7ace4eb5f1af193d64d156243904300e1f5fc66d1a44f578970e0d8242be3c8fa82804bfc975efcaaf6b5289c0b09b22b8d5c069fc81a16c343136be49b SHA512 695ba6e596411fdda14e6800163b934dba2dc6ee661ebc91a9f3d3509b9568d0482108fb50503953f7f9186cf11724c0faf4660436aad1929f4a70dc41286402
diff --git a/net-misc/sipsak/sipsak-0.9.7.ebuild b/net-misc/sipsak/sipsak-0.9.7.ebuild
new file mode 100644
index 000000000000..ddc1785dbe0a
--- /dev/null
+++ b/net-misc/sipsak/sipsak-0.9.7.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+DESCRIPTION="small command line tool for testing SIP applications and devices"
+HOMEPAGE="https://github.com/nils-ohlmeier/sipsak"
+SRC_URI="https://github.com/nils-ohlmeier/sipsak/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="net-libs/gnutls
+ net-dns/c-ares"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ append-cflags -std=gnu89 -fcommon
+ econf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}