summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2016-10-07 07:30:35 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-10-31 12:58:48 +0100
commit726ea3e6f3781aced5f1f49bdbd08ee1a884bc56 (patch)
treefa82e4627aaad7d48a0923cac3657c96f4aee407
parentapp-vim/pydoc: stable for x86. mark stable for the remaining arches whilst at... (diff)
downloadgentoo-726ea3e6.tar.gz
gentoo-726ea3e6.tar.bz2
gentoo-726ea3e6.zip
dev-ruby/hashicorp-checkpoint: add ruby23 support, drop ~x86.
Package-Manager: portage-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/2501 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
-rw-r--r--dev-ruby/hashicorp-checkpoint/hashicorp-checkpoint-0.1.4-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/hashicorp-checkpoint/hashicorp-checkpoint-0.1.4-r1.ebuild b/dev-ruby/hashicorp-checkpoint/hashicorp-checkpoint-0.1.4-r1.ebuild
new file mode 100644
index 000000000000..3f4e99613f80
--- /dev/null
+++ b/dev-ruby/hashicorp-checkpoint/hashicorp-checkpoint-0.1.4-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Internal HashiCorp service to check version information"
+HOMEPAGE="http://www.hashicorp.com"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+ruby_add_bdepend "
+ test? ( dev-ruby/rspec-its )
+"