summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2018-10-15 09:45:28 -0400
committerCraig Andrews <candrews@gentoo.org>2018-10-15 09:49:03 -0400
commit7368401975ebbc2083d523ca058bc36fe6a205c3 (patch)
tree51e2d1d5472484d1ea648a040685f40ac6181550
parentwww-client/chromium: copy CHROMIUM_FORCE_CLANG for M69 and M70 (diff)
downloadgentoo-73684019.tar.gz
gentoo-73684019.tar.bz2
gentoo-73684019.zip
www-apache/mod_h2: 1.11.3 version bump; always run eautoreconf
Run eautoreconf to fix QA notice: `../libtool: line 7902: func_munge_path_list: command not found` Signed-off-by: Craig Andrews <candrews@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--www-apache/mod_h2/Manifest1
-rw-r--r--www-apache/mod_h2/mod_h2-1.11.3.ebuild47
-rw-r--r--www-apache/mod_h2/mod_h2-9999.ebuild8
3 files changed, 52 insertions, 4 deletions
diff --git a/www-apache/mod_h2/Manifest b/www-apache/mod_h2/Manifest
index e01c6c36c66c..d6d5ffbf6015 100644
--- a/www-apache/mod_h2/Manifest
+++ b/www-apache/mod_h2/Manifest
@@ -1 +1,2 @@
DIST mod_http2-1.10.10.tar.gz 528560 BLAKE2B 7389441b1d30d0448bb17fc02a73957cf20365020796ce7260c1d63d1468537ecdeab83db12d1b245af1e760236da8e8d0ccf9ffb222d2dec1e55491ac77dc11 SHA512 b4b9e734ed35ca63fa114462f1adb358bb73e4cbd8df95ab28c4518b8f7db40233f4ba13bc2194847eb9c1adbc3eb86fc63cbb56389fc0867767658d4d8ba77b
+DIST mod_http2-1.11.3.tar.gz 1028467 BLAKE2B 3a5d644f87104e1f7baae05396fefe94975e86e9289bb9c4e6d7ed94e45e1d9b38dfc79d0e0d9ee9270efedcd811db2374c898e419d4c16f73b38f53512e91ed SHA512 b97697f44eab9984b7dcaa7d941f23375cd5c2c81405842e17910a37dc2c952fc36a37e0802755457ccedd196c5fd2fb5b60467cb0ed16ed7aeb88cce4eabd2f
diff --git a/www-apache/mod_h2/mod_h2-1.11.3.ebuild b/www-apache/mod_h2/mod_h2-1.11.3.ebuild
new file mode 100644
index 000000000000..7a124f105c05
--- /dev/null
+++ b/www-apache/mod_h2/mod_h2-1.11.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit apache-module autotools
+
+MY_P="${PN/h2/http2}-${PV}"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/icing/mod_h2.git"
+ inherit git-r3
+else
+ S="${WORKDIR}/${MY_P}"
+ SRC_URI="https://github.com/icing/mod_h2/releases/download/v${PV}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="HTTP/2 module for Apache"
+HOMEPAGE="https://github.com/icing/mod_h2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="ssl"
+
+RDEPEND=">=net-libs/nghttp2-1.0
+ >=www-servers/apache-2.4.20[-apache2_modules_http2,ssl?]"
+DEPEND="${RDEPEND}"
+
+need_apache2_4
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ default
+
+ APACHE2_MOD_DEFINE="HTTP2"
+ insinto "${APACHE_MODULES_CONFDIR}"
+ newins "${FILESDIR}/mod_http2.conf" "41_mod_http2.conf"
+}
diff --git a/www-apache/mod_h2/mod_h2-9999.ebuild b/www-apache/mod_h2/mod_h2-9999.ebuild
index eaf87ecaf6b9..7a124f105c05 100644
--- a/www-apache/mod_h2/mod_h2-9999.ebuild
+++ b/www-apache/mod_h2/mod_h2-9999.ebuild
@@ -1,15 +1,15 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
-inherit apache-module
+inherit apache-module autotools
MY_P="${PN/h2/http2}-${PV}"
if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://github.com/icing/mod_h2.git"
- inherit autotools git-r3
+ inherit git-r3
else
S="${WORKDIR}/${MY_P}"
SRC_URI="https://github.com/icing/mod_h2/releases/download/v${PV}/${MY_P}.tar.gz"
@@ -31,7 +31,7 @@ need_apache2_4
src_prepare() {
default
- [[ ${PV} = 9999 ]] && eautoreconf
+ eautoreconf
}
src_compile() {