summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-08-29 19:34:14 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-29 19:37:02 +0100
commit7565ebf9869d82b8df48028cef12eb16b96714f8 (patch)
treea6184d083defae15275674f19bfb66a20b664b76
parentdev-haskell/postgresql-libpq: new package, a depend of esqueleto-3.3 (diff)
downloadgentoo-7565ebf9.tar.gz
gentoo-7565ebf9.tar.bz2
gentoo-7565ebf9.zip
dev-haskell/inspection-testing: new package, a depend of esqueleto-3.3
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--dev-haskell/inspection-testing/Manifest1
-rw-r--r--dev-haskell/inspection-testing/inspection-testing-0.4.2.4.ebuild34
-rw-r--r--dev-haskell/inspection-testing/metadata.xml33
3 files changed, 68 insertions, 0 deletions
diff --git a/dev-haskell/inspection-testing/Manifest b/dev-haskell/inspection-testing/Manifest
new file mode 100644
index 000000000000..a3e6a9a7782b
--- /dev/null
+++ b/dev-haskell/inspection-testing/Manifest
@@ -0,0 +1 @@
+DIST inspection-testing-0.4.2.4.tar.gz 20946 BLAKE2B 20547c5a231083391c886fcef8b3dc153fde8498d9268a297013691a055c65dc93deb31b5988a8cdf1e32d465344802153448850a89b819744551dc13712a1a2 SHA512 16ebfcd20e4ee3a9117670ad9e0d683002262a2f3c52dcfdb7c7123f256db4f133780e759a80469a14c786a4158ef9ba4e7d534e728e8d44188b11765a1e8745
diff --git a/dev-haskell/inspection-testing/inspection-testing-0.4.2.4.ebuild b/dev-haskell/inspection-testing/inspection-testing-0.4.2.4.ebuild
new file mode 100644
index 000000000000..88c02ec0b857
--- /dev/null
+++ b/dev-haskell/inspection-testing/inspection-testing-0.4.2.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.4.9999
+#hackport: flags: -more-tests
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # Broken test-suite: compiler-dependent
+inherit haskell-cabal
+
+DESCRIPTION="GHC plugin to do inspection testing"
+HOMEPAGE="https://github.com/nomeata/inspection-testing"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # examples/Fusion.hs:22:1: sumUp1 === sumUp2 failed
+
+RDEPEND="dev-haskell/mtl:=[profile?]
+ >=dev-lang/ghc-8.0.1:=
+ >=dev-lang/ghc-8.0.2:=[profile?] <dev-lang/ghc-8.11:=[profile?]
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.24.0.0
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-more-tests
+}
diff --git a/dev-haskell/inspection-testing/metadata.xml b/dev-haskell/inspection-testing/metadata.xml
new file mode 100644
index 000000000000..f4d3257dab77
--- /dev/null
+++ b/dev-haskell/inspection-testing/metadata.xml
@@ -0,0 +1,33 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ Some carefully crafted libraries make promises to their
+ users beyond functionality and performance.
+
+ Examples are: Fusion libraries promise intermediate data
+ structures to be eliminated. Generic programming libraries promise
+ that the generic implementation is identical to the
+ hand-written one. Some libraries may promise allocation-free
+ or branch-free code.
+
+ Conventionally, the modus operandi in all these cases is
+ that the library author manually inspects the (intermediate or
+ final) code produced by the compiler. This is not only
+ tedious, but makes it very likely that some change, either
+ in the library itself or the surrounding eco-system,
+ breaks the library's promised without anyone noticing.
+
+ This package provides a disciplined way of specifying such
+ properties, and have them checked by the compiler. This way,
+ this checking can be part of the ususal development cycle
+ and regressions caught early.
+
+ See the documentation in &quot;Test.Inspection&quot; or the project
+ webpage for more examples and more information.
+ </longdescription>
+</pkgmetadata>