summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-04-21 23:52:31 +0100
committerMarek Szuba <marecki@gentoo.org>2020-04-21 23:57:58 +0100
commit7742f6fca5b241186ae1360c4b319d41b0967f54 (patch)
tree5f94824991eff8e0c2bc545bbccceba452f56f72
parentapp-misc/gramps: work around problems with --skip-build (diff)
downloadgentoo-7742f6fca5b241186ae1360c4b319d41b0967f54.tar.gz
gentoo-7742f6fca5b241186ae1360c4b319d41b0967f54.tar.bz2
gentoo-7742f6fca5b241186ae1360c4b319d41b0967f54.zip
dev-python/vdf: support pypy3, simplify test dependencies
pypy3 - builds and tests fine, as claimed by upstream Test dependencies - Python-3.3 and newer have unittest.mock in the standard library and this package does not support any versions older than that, patch the relevant test file to use unittest.mock and stop pulling in dev-python/mock (which was pulled in incorrectly anyway). Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--dev-python/vdf/files/vdf-3.2-mock_from_stdlib.patch9
-rw-r--r--dev-python/vdf/vdf-3.2-r1.ebuild22
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/vdf/files/vdf-3.2-mock_from_stdlib.patch b/dev-python/vdf/files/vdf-3.2-mock_from_stdlib.patch
new file mode 100644
index 000000000000..511e5dd1ddc3
--- /dev/null
+++ b/dev-python/vdf/files/vdf-3.2-mock_from_stdlib.patch
@@ -0,0 +1,9 @@
+--- a/tests/test_vdf.py
++++ b/tests/test_vdf.py
+@@ -1,5 +1,5 @@
+ import unittest
+-import mock
++import unittest.mock as mock
+ import sys
+
+ try:
diff --git a/dev-python/vdf/vdf-3.2-r1.ebuild b/dev-python/vdf/vdf-3.2-r1.ebuild
new file mode 100644
index 000000000000..2c3eaf316de0
--- /dev/null
+++ b/dev-python/vdf/vdf-3.2-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A module for (de)serialization to and from VDF, Valve's key-value text format"
+HOMEPAGE="https://github.com/ValvePython/vdf"
+SRC_URI="https://codeload.github.com/ValvePython/${PN}/tar.gz/v${PV} -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.2-mock_from_stdlib.patch
+)
+
+distutils_enable_tests pytest