summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-12 17:06:27 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-12 18:51:37 +0100
commit779c9f0b072e30e712e1928587b49f00faa97ee2 (patch)
treee8f55b14a7d8d2b780f85ec7c7cb3ec88fdd6fbc
parentdev-python/nbformat: Bump to 5.10.2 (diff)
downloadgentoo-779c9f0b072e30e712e1928587b49f00faa97ee2.tar.gz
gentoo-779c9f0b072e30e712e1928587b49f00faa97ee2.tar.bz2
gentoo-779c9f0b072e30e712e1928587b49f00faa97ee2.zip
dev-python/google-api-python-client: Bump to 2.122.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/google-api-python-client/Manifest1
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.122.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index 69e4bb3fbb78..a5bbd9bed624 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -1,3 +1,4 @@
DIST google-api-python-client-2.119.0.tar.gz 11704086 BLAKE2B ff7d2eb62559a042a272a4493ac9eb4e25f0a91dd085c172a6356e952e346d2d79d1818b57bc258725065bd19e72d9e787b021e17672361e8ff02b08b1be65cb SHA512 2acd84b059f3500e45398d2de4d6cab0941c40d7c501414c358992d6f0b305349213a2f96372a4d8b091202c87692e337036c213425b0813cc9203c5d323d966
DIST google-api-python-client-2.120.0.tar.gz 11753415 BLAKE2B 27466bed3bfc473dc1ce8ab6d7e6834b5b5010d39afc20ba8204b379621146e9a1523e18a7d1073cdafd1e7f1840832e371cfedf43689fb825917a73dd64be6c SHA512 303733940a2415e6e18ce4ba2c423ae0e85ce3746f4282698178cf7c2e70244b159fa4a22af6ce39cdeafb8d91db237cc40a1abfef33e1c8aa3add4f031aac23
DIST google-api-python-client-2.121.0.tar.gz 11796461 BLAKE2B 178665ad75d5e8fa2437c909b47cf93c566e4f47cfc2e6a0fd74d9f7de29dc4076bf86299c42341e3c32b3ab20723a89fc062629964dfc2cc02a2eeaa0a1fcb0 SHA512 2bb2d02b93656d349ed65ccaa85dc435aae0ebb7d45edf2dd9b6aecb56cd8866421f4359612830e5d32d0609df12252e550ed514bf3c6b63920a67ffe74f6299
+DIST google-api-python-client-2.122.0.tar.gz 11884905 BLAKE2B e22e9cc1b7e2afebbf0a1793e4d2c96d7e3d4b38e7266213d57b8db2eeedcc6c37a18bd0cc62c50fa84221dfea2bfc1ebd9c0cbe33fe4921662e50dd26ccde5d SHA512 dc17be212b975d700ca8ea333d0b1b7207f48cd870190154e14b94d5ae3f835c8f1fe63ed1ac267b1a1ab8a6916a6d55c479d5728801bbc74f842231eef71049
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.122.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.122.0.ebuild
new file mode 100644
index 000000000000..c5a2303ef5ac
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.122.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="
+ https://github.com/googleapis/google-api-python-client/
+ https://pypi.org/project/google-api-python-client/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ >=dev-python/google-api-core-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ )
+
+ epytest tests
+}