summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2022-06-26 13:46:10 +0100
committerMatthew Smith <matthew@gentoo.org>2022-06-26 13:54:19 +0100
commit78147a1e291cd661a15126c31ff4374675609a94 (patch)
tree01fbdecc3e8fe07c8dbe19df1fdf48c265b08ade
parentnet-mail/mu: add 1.8.1 (diff)
downloadgentoo-78147a1e.tar.gz
gentoo-78147a1e.tar.bz2
gentoo-78147a1e.zip
sys-devel/mold: use pkg-config to find OpenSSL
Signed-off-by: Matthew Smith <matthew@gentoo.org>
-rw-r--r--sys-devel/mold/files/mold-1.3.0-openssl-pkgconfig.patch28
-rw-r--r--sys-devel/mold/mold-9999.ebuild1
2 files changed, 29 insertions, 0 deletions
diff --git a/sys-devel/mold/files/mold-1.3.0-openssl-pkgconfig.patch b/sys-devel/mold/files/mold-1.3.0-openssl-pkgconfig.patch
new file mode 100644
index 000000000000..d2ed0af47b41
--- /dev/null
+++ b/sys-devel/mold/files/mold-1.3.0-openssl-pkgconfig.patch
@@ -0,0 +1,28 @@
+From a4fde946f49cddf4f7c1eceb3b86ca38375cec1d Mon Sep 17 00:00:00 2001
+From: Matthew Smith <matt@offtopica.uk>
+Date: Sun, 26 Jun 2022 13:44:36 +0100
+Subject: [PATCH] Revert "Do not use pkg-config"
+
+This reverts commit 4ef90d4316bbba3a4b8902e38bf5f68171cc6ab7.
+--- a/Makefile
++++ b/Makefile
+@@ -18,6 +18,9 @@ ifeq ($(origin CXX), default)
+ CXX = c++
+ endif
+
++# Allow overriding pkg-config binary
++PKG_CONFIG = pkg-config
++
+ # If you want to keep symbols in the installed binary, run make with
+ # `STRIP=true` to run /bin/true instead of the strip command.
+ STRIP = strip
+@@ -100,7 +103,8 @@ ifeq ($(OS), Darwin)
+ endif
+
+ ifeq ($(NEEDS_LIBCRYPTO), 1)
+- MOLD_LDFLAGS += -lcrypto
++ MOLD_CXXFLAGS += $(shell $(PKG_CONFIG) --cflags-only-I openssl)
++ MOLD_LDFLAGS += $(shell $(PKG_CONFIG) --libs-only-L openssl) -lcrypto
+ endif
+
+ # '-latomic' flag is needed building on riscv64 system.
diff --git a/sys-devel/mold/mold-9999.ebuild b/sys-devel/mold/mold-9999.ebuild
index 87931221e192..d5c163c1ba90 100644
--- a/sys-devel/mold/mold-9999.ebuild
+++ b/sys-devel/mold/mold-9999.ebuild
@@ -31,6 +31,7 @@ DEPEND="${RDEPEND}"
PATCHES=(
# Bug #841575
"${FILESDIR}"/${PN}-1.2.1-install-nopython.patch
+ "${FILESDIR}"/${PN}-1.3.0-openssl-pkgconfig.patch
)
pkg_pretend() {