summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZamarin Arthur <arthurzam@gmail.com>2021-05-21 21:03:14 +0300
committerMichał Górny <mgorny@gentoo.org>2021-05-22 20:18:05 +0200
commit7879e10e17d28b7b5558e0b63a51b77614d97880 (patch)
treec474a2b317d509f3b40ccee1e5f9d9cb3820feeb
parentdev-python/multidict: bump to python 3.10 (diff)
downloadgentoo-7879e10e17d28b7b5558e0b63a51b77614d97880.tar.gz
gentoo-7879e10e17d28b7b5558e0b63a51b77614d97880.tar.bz2
gentoo-7879e10e17d28b7b5558e0b63a51b77614d97880.zip
dev-python/yarl: bump to python 3.10
passes tests Signed-off-by: Zamarin Arthur <arthurzam@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/yarl/yarl-1.6.3.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-python/yarl/yarl-1.6.3.ebuild b/dev-python/yarl/yarl-1.6.3.ebuild
index dd7465b90388..edbd40587577 100644
--- a/dev-python/yarl/yarl-1.6.3.ebuild
+++ b/dev-python/yarl/yarl-1.6.3.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
inherit distutils-r1
@@ -19,7 +20,7 @@ RDEPEND="
>=dev-python/idna-2.0[${PYTHON_USEDEP}]
$(python_gen_cond_dep '
>=dev-python/typing-extensions-3.7.4[${PYTHON_USEDEP}]
- ' python3_{6,7} pypy3)
+ ' python3_7 pypy3)
"
distutils_enable_tests pytest